Maybe mplayer engine is better?

Asked by Ivan Ivanoff

Because when I use xine I am getting chunky video and sound after this:
Me TV-Message: 09.06.2008 23:00:15 - About to play from FIFO ...
Me TV-Message: 09.06.2008 23:53:15 - Playing from FIFO
Me TV-Message: Exception message: 'Timeout while polling for demuxer'
- I changed engine to "mplayer" in me-tv.config. It works good, but I cannot get normal fullscreen. And when I resize video window - it becomes ugly: edges of images from video remains.

What am I doing not right?

Question information

English Edit question
Me TV Edit question
No assignee Edit question
Solved by:
Ivan Ivanoff
Last query:
Last reply:
Revision history for this message
Michael Lamothe (lamothe-deactivatedaccount-deactivatedaccount) said :

Don't use the mplayer engine. I don't support it. It's there as a debugging tool.

* Where are you?
* What version are you using?
* What type of video card do you have?
* What video drivers are you using?

Revision history for this message
Ivan Ivanoff (spammeroff) said :

But it works. And for me - with good audio-video sync. But with some ugly artifacts when resizing. I was thinking xine engine is no more supported.
1). I am from Vladivostok, Russia. I use ABS 1 at 75.0°E.
2). GNOME me-tv 0.5.27 from your repository in Ubuntu 7.10. Thank you for package! I use it with TechnoTrend TT1401-S.
3). I have i915G integrated video card with 128 Mb aperture and 64 Mb shared video memory (it takes from 2048 Mb RAM)
4). I use standard intel driver and x11 interface with Compiz Fusion. I do not think that it caused from video part. It is DVB problem. I used to use "mplayer -demuxer mpegts dvb:///" before I found your program.

I hope it will be useful for You! Any tests are welcome!

Revision history for this message
Michael Lamothe (lamothe-deactivatedaccount-deactivatedaccount) said :

Try disabling compiz, I know that I have issue with it on my ATI card. Also, when using the xine engine, have you tried switching to the xshm output in the preferences dialog.



Revision history for this message
Ivan Ivanoff (spammeroff) said :

I do not want to disable compiz! Compiz is so... I have no words. I have tried switching to "auto" and "xshm" either - the same effect. It sounds and looks like signal interruption. But it happens on a small enough term - about 2-3 sec.
I have changed values of buffers in tenth times bigger (xine.config), it helped! Now video and sound run smoothly.


Are these parameters more then I need?

Revision history for this message
Michael Lamothe (lamothe-deactivatedaccount-deactivatedaccount) said :

I was merely suggesting that you disable Compiz as a test, I also run compiz even though it messes with video.

That's all you need to do, if it doesn't chew up too much memory then I guess that those values are fine. Thanks for the feedback.