Error message while testing

Asked by Jong-Min Lee on 2010-08-23

Hi,

I downloaded Matlab BGL 4.01. The system is Linux 64 bit and the Matlab is 7.6.0 (R2008a). I downloaded, extracted and copied the toolbox. And, I set the path in the Matlab. After it was recommended in the manual, I tested if the toolbox is installed correctly or not. When I typed the command ">> clustering_coefficients(sparse(ones(5)))", the error message was displayed like:
??? Undefined function or variable 'get_matlab_bgl_options'.
Error in ==> clustering_coefficients at 45
[trans check full2sparse] = get_matlab_bgl_options(varargin{:});

So, I wanted to check if the precompiled the library correctly, but I don't know which one is the library. Could you help me with that?

Thank you.
Jong-Min Lee

Question information

Language:
English Edit question
Status:
Answered
For:
Matlab BGL Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
David Gleich (dgleich) said :
#1

My guess is that you don't have the path set correctly. The get_matlab_bgl_options file is in a private subdirectory. Try this:

(typed from memory, so some of the paths/filenames may be off -- it should be obvious what the correction is...)

>> unzip matlab-bgl-4.01.zip
>> cd matlab-bgl
>> clustering_coefficients(sparse(ones(5)))

The key thing is to make sure that the directory _ABOVE_ the private one is on the matlab path. (And that all the contents of the private directory are there.)

Revision history for this message
Jong-Min Lee (wntsea) said :
#2

Hi,

The followings are what I tired:

1. I tried to add all the folders with subfolders of matlab_bgl, but found
that the private folder was not included. So, I tried to add private folder,
but is showed error message like "You cannot add method folders (ones that
start with '@") or private folders to the MATLAB search path.

2. I changed the name of private folder to private2. And, I added the
private2 folder, but I couldn't run
'>>clustering_coefficients(sparse(ones(5)))'. It showed the same error
message that Matlab couldn't find 'get_matlab_bgl_options'.

3. I moved to the private directory like
"cd('/~~~/matlab/matlab_bgl/private") and still couldn't run couldn't run
'>>clustering_coefficients(sparse(ones(5)))'
So, I am not sure if it is a path problem. Could you tell me if anothe way
to check it?

Thank you.
Jong-Min Lee
2010/8/23 David Gleich <email address hidden>

> Your question #122439 on Matlab BGL changed:
> https://answers.launchpad.net/matlab-bgl/+question/122439
>
> Status: Open => Answered
>
> David Gleich proposed the following answer:
> My guess is that you don't have the path set correctly. The
> get_matlab_bgl_options file is in a private subdirectory. Try this:
>
> (typed from memory, so some of the paths/filenames may be off -- it
> should be obvious what the correction is...)
>
> >> unzip matlab-bgl-4.01.zip
> >> cd matlab-bgl
> >> clustering_coefficients(sparse(ones(5)))
>
> The key thing is to make sure that the directory _ABOVE_ the private one
> is on the matlab path. (And that all the contents of the private
> directory are there.)
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/matlab-bgl/+question/122439/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/matlab-bgl/+question/122439
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Please not reply directly to this e-mail, but to <email address hidden>.

Jong-Min Lee
****************************************************
Jong-Min Lee, PhD
Computational NeuroImage Analysis Lab.,
Dept. of Biomedical Engineering, Hanyang University

Mailing Address: Sundong P.O. Box 55, Seoul, KOREA, 133-605
Office: +82-2-2220-0685, Lab: +82-2-2220-0697
FAX: +82-2-2296-5943
E-mail: <email address hidden>; <email address hidden>
Homepage: http://cna.hanyang.ac.kr
******************************************************

Revision history for this message
David Gleich (dgleich) said :
#3

There must be something really weird with your path.

Try copying the contents of the private directory into the main matlab
bgl directory and see if that works.

David

On Thu, Aug 26, 2010 at 9:54 AM, Jong-Min Lee
<email address hidden> wrote:
> Question #122439 on Matlab BGL changed:
> https://answers.launchpad.net/matlab-bgl/+question/122439
>
>    Status: Answered => Open
>
> Jong-Min Lee is still having a problem:
> Hi,
>
> The followings are what I tired:
>
> 1. I tried to add all the folders with subfolders of matlab_bgl, but found
> that the private folder was not included. So, I tried to add private folder,
> but is showed error message like "You cannot add method folders (ones that
> start with '@") or private folders to the MATLAB search path.
>
> 2. I changed the name of private folder to private2. And, I added the
> private2 folder, but I couldn't run
> '>>clustering_coefficients(sparse(ones(5)))'. It showed the same error
> message that Matlab couldn't find 'get_matlab_bgl_options'.
>
> 3. I moved to the private directory like
> "cd('/~~~/matlab/matlab_bgl/private") and still couldn't run couldn't run
> '>>clustering_coefficients(sparse(ones(5)))'
> So, I am not sure if it is a path problem. Could you tell me if anothe way
> to check it?
>
> Thank you.
> Jong-Min Lee
> 2010/8/23 David Gleich <email address hidden>
>
>> Your question #122439 on Matlab BGL changed:
>> https://answers.launchpad.net/matlab-bgl/+question/122439
>>
>>    Status: Open => Answered
>>
>> David Gleich proposed the following answer:
>> My guess is that you don't have the path set correctly.  The
>> get_matlab_bgl_options file is in a private subdirectory.  Try this:
>>
>> (typed from memory, so some of the paths/filenames may be off -- it
>> should be obvious what the correction is...)
>>
>> >> unzip matlab-bgl-4.01.zip
>> >> cd matlab-bgl
>> >> clustering_coefficients(sparse(ones(5)))
>>
>> The key thing is to make sure that the directory _ABOVE_ the private one
>> is on the matlab path.  (And that all the contents of the private
>> directory are there.)
>>
>> --
>> If this answers your question, please go to the following page to let us
>> know that it is solved:
>>
>> https://answers.launchpad.net/matlab-bgl/+question/122439/+confirm?answer_id=0
>>
>> If you still need help, you can reply to this email or go to the
>> following page to enter your feedback:
>> https://answers.launchpad.net/matlab-bgl/+question/122439
>>
>>  You received this question notification because you are a direct
>> subscriber of the question.
>>
>
>
> --
> Please not reply directly to this e-mail, but to <email address hidden>.
>
> Jong-Min Lee
> ****************************************************
> Jong-Min Lee, PhD
> Computational NeuroImage Analysis Lab.,
> Dept. of Biomedical Engineering, Hanyang University
>
> Mailing Address: Sundong P.O. Box 55, Seoul, KOREA, 133-605
> Office: +82-2-2220-0685, Lab: +82-2-2220-0697
> FAX: +82-2-2296-5943
> E-mail: <email address hidden>; <email address hidden>
> Homepage: http://cna.hanyang.ac.kr
> ******************************************************
>
> You received this question notification because you are an answer
> contact for Matlab BGL.
>

Revision history for this message
Jong-Min Lee (wntsea) said :
#4

Hi,

Thank you for your help. But, I can't solve the issue. In fact, I did the same process in my macbook pro and the result was the same:
??? Undefined function of method 'clustering_coefficients_mex' for input arguements of type 'double'.
Error in ==> clustering_coefficients at 97
ccfs=clustering_coefficients_mex(A,options,undirected,weight_arg);

I tried to 1) change the name of the directory 'private' to 'private2' and 2) copy all the files in the 'private' to the upper directory. Buy the way, the path 'private' can't be added to the matlab path. I thought it was related to the Linux server, but it is the same case in my macbook pro.

I found there are several files named 'clustering_coefficients_mex.*'. I don't know how to work.When I call the function 'clustering_coefficients_mex', does it automatically call the suitable file, for example, 'clustering_coefficients_mex.mexmaci'? Do I have to set up some initial value for this kind of parameter?

Could you help me one more time? I need to use this library.

Thank you.
Jong-Min Lee

Revision history for this message
David Gleich (dgleich) said :
#5

This is a different issue -- see the mathworks page for a link to an
update zip file for the mac osx platform.

David

On Mon, Aug 30, 2010 at 4:29 PM, Jong-Min Lee
<email address hidden> wrote:
> Question #122439 on Matlab BGL changed:
> https://answers.launchpad.net/matlab-bgl/+question/122439
>
>    Status: Answered => Open
>
> Jong-Min Lee is still having a problem:
> Hi,
>
> Thank you for your help. But, I can't solve the issue. In fact, I did the same process in my macbook pro and the result was the same:
> ??? Undefined function of method 'clustering_coefficients_mex' for input arguements of type 'double'.
> Error in ==> clustering_coefficients at 97
> ccfs=clustering_coefficients_mex(A,options,undirected,weight_arg);
>
> I tried to 1) change the name of the directory 'private' to 'private2'
> and 2) copy all the files in the 'private' to the upper directory. Buy
> the way, the path 'private' can't be added to the matlab path. I thought
> it was related to the Linux server, but it is the same case in my
> macbook pro.
>
> I found there are several files named 'clustering_coefficients_mex.*'. I
> don't know how to work.When I call the function
> 'clustering_coefficients_mex', does it automatically call the suitable
> file, for example, 'clustering_coefficients_mex.mexmaci'? Do I have to
> set up some initial value for this kind of parameter?
>
> Could you help me one more time? I need to use this library.
>
> Thank you.
> Jong-Min Lee
>
> --
> You received this question notification because you are an answer
> contact for Matlab BGL.
>

Revision history for this message
Henric (henric-ryden) said :
#6

I have the exact same problem, as if the files are not on my path. I'm using Windows 7 64-bit.

Revision history for this message
David Gleich (dgleich) said :
#7

See the github page for a newly compiled set of win64 binaries:

https://github.com/dgleich/matlab-bgl/wiki/Frequently-Asked-Questions

David

On Wed, Feb 15, 2012 at 2:55 AM, Henric
<email address hidden> wrote:
> Question #122439 on Matlab BGL changed:
> https://answers.launchpad.net/matlab-bgl/+question/122439
>
> Henric requested more information:
> I have the exact same problem, as if the files are not on my path. I'm
> using Windows 7 64-bit.
>
> --
> You received this question notification because you are an answer
> contact for Matlab BGL.

Can you help with this problem?

Provide an answer of your own, or ask Jong-Min Lee for more information if necessary.

To post a message you must log in.