Build dependencies

Asked by Redge on 2013-10-12

I'm trying to build the trunk myself, but I keep getting errors. The INSTALL instructions are pretty clear, but they don't list dependencies. So far I've figured out that I needed to install valac. What else do I need to build this?

Question information

Language:
English Edit question
Status:
Answered
For:
Marlin Edit question
Assignee:
No assignee Edit question
Last query:
2013-11-10
Last reply:
2013-11-10
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Alright, I think I have the dependencies more or less figured out:

sudo apt-get install valac libpango-1.0-0 libgee2 libsqlite3-0 libunity-dev libgtk-3-dev libvarka-dev libnotify-dev libgail-3-dev

Yep, it compiles.

ammonkey (am-monkeyd) said : #4

Beside vala > 0.16 here is the list of the required dependencies (as provided in the different CMakeList):
varka>=0.1 glib-2.0>=2.35.4 gthread-2.0 gio-2.0 gio-unix-2.0 pango>=1.1.2 gtk+-3.0>=3.0.3 gail-3.0 gee-1.0 sqlite3 dbus-glib-1 libnotify>=0.7.2

unity is an optional dependencie, it s not a required to compile.

Under a debian like system the dependancies packages should be (as provided in the debian control file) :

Build-Depends: debhelper (>= 7), pkg-config, cmake, valac-0.16 | valac (>= 0.16.0), libglib2.0-dev (>= 2.36), libpango1.0-dev (>= 1.1.2), libgtk-3-dev (>= 3.10), libgee-0.8-dev, libvarka-dev, libsqlite3-dev, libnotify4-dev (>= 0.7.2) | libnotify-dev (>= 0.7.2), gnome-common, libgail-3-dev, libdbus-glib-1-dev, libunity-dev (>= 4.0.0)

Can you help with this problem?

Provide an answer of your own, or ask Redge for more information if necessary.

To post a message you must log in.