Right Click / Open terminal

Asked by Xavier on 2011-12-10

Hi !

The item 'Right Clic/ open terminal' seems to not work with xfce/xubuntu. Is there a special seting for xfce ?

Thanks.
X'.

Question information

Language:
English Edit question
Status:
Solved
For:
Marlin Edit question
Assignee:
No assignee Edit question
Solved by:
Xavier
Solved:
2011-12-25
Last query:
2011-12-25
Last reply:
2011-12-24
Roberto Burgos (roby0b) said : #1

It opened the terminal but not to the folder I pointed it at, just to my root folder.

Xavier (xavier-monset) said : #2

I'm sorry but on my two laptops, the terminal doesn't open.... :s
Xubuntu 11.10 32 & 64 bits. Marlin 0.1

ammonkey (am-monkeyd) said : #3

extended-actions provide terminal via gnome-terminal.
It's likely you don't have gnome-terminal installed which is why it don't work.

I don't know how to get a default terminal, it seems each environment, DE, WM got a custom setting for it.
I am not aware of anything common.

what you can do is copying the extended action file /usr/share/extended-actions/gnome-terminal.desktop to ~/.local/share/extended-actions/gnome-terminal.desktop
then edit the file and change gnome-terminal to your favorite terminal. Don't forget to change the variable i doubt --working-directory work with other term (check the manpage of your terminal).

extended action local file override the system one.

Xavier (xavier-monset) said : #4

Hi !

I did as you told me and that's work fine.

With xfce, you should use this gnome-terminal.desktop :

[Extended Action Entry]
Name=Terminal
Icon=utilities-terminal
Description=Open in Terminal
MimeType=inode/directory
Exec=exo-open --launch TerminalEmulator --working-directory %f

Thanks a lot !

postNuKe (dmacias2000) said : #5

yeah perfect, works fine thanks

David Segura M (davidseg) said : #6

Thanks a lot work for me too. how should I modify that entry for adding an action for open in terminal as root?