INSTALL_maverick and taskview-glib

Asked by zpletan on 2010-12-27

configure: error: Package requirements (
 [cut for brevity]
        taskview-glib-1.0
) were not met:

No package 'taskview-glib-1.0' found

How do I fix this (on Maverick)? The fix also needs to go in the INSTALL_maverick file.

Question information

Language:
English Edit question
Status:
Solved
For:
Marlin Edit question
Assignee:
No assignee Edit question
Solved by:
zpletan
Solved:
2010-12-29
Last query:
2010-12-29
Last reply:
2010-12-28

This question was originally filed as bug #694730.

ammonkey (am-monkeyd) said : #1

Hello,

taskview has been added as a dependency. I've choosen this lib to regroup all the file operations. There's many differents ways we can visualize file transfert with it, like with an indicator or a Transfert file operations tab (something like Downloads for chromium). An "indicator" sitting in the statusbar can be nice too. The design of file transfert is not done yet, it's something we have to define. As u see there's many possibilities than the tradionnal isolated Progress Transfert Window. And we can group file operations from other application too like empathy etc ...

You can find the libs there:
https://github.com/ssickert/TaskView
https://github.com/ssickert/TaskView-Addons

Installation is standard
./autogen.sh --prefix=/usr
make && sudo make install

maybe in TaskView-Addons git u'll got to create some files missing from the repository, like po folder or NEWS file. configure script would complain and indicate you the way to follow.

Ps: i marked this as a question like it's not a bug, just a new dependancy like many others to install marlin.
INSTALL_maverick is just an helper script and there's no garantee for it to be up to date. I for one don't use maverick anymore so i can't really check this script.

zpletan (zpletan) said : #2

The following ought to make marlin compile for maverick users again (as far as I know).

git clone git://github.com/ssickert/TaskView.git
cd TaskView
./autogen.sh --prefix=/usr
make && sudo make install
cd ..

git clone https://github.com/ssickert/TaskView-Addons.git
cd TaskView-Addons
sudo apt-get install libtelepathy-glib-dev
mkdir po ; touch NEWS #Don't ask me why we should have to do this, but we do...
./autogen.sh --prefix=/usr
make && sudo make install
cd ..

Can anyone confirm if this works? I just wrote that based on what I did; I didn't test it.

zpletan (zpletan) said : #3

It works for me, so I'm marking it solved. (Would it be good to have more-or-less up-to-date install instructions for Maverick in an FAQ for marlin? Just a thought...)

Adnane Belmadiaf (daker) said : #4

I have updated the INSTALL_maverick script, we just need to wait until it's merged into the trunk

Andrea Azzarone (azzar1) said : #5

When i run:
./autogen.sh --prefix=/usr

I get the following error:
grep: po/Makefile.in: No such file or directory
config.status: error: po/Makefile.in.in was not created by intltoolize.

How i can solve?

zpletan (zpletan) said : #6

I don't know. Unfortunately, I also have no spare time to devote to fooling around with the new stuff from elementary anymore, so I can't figure out either. You did the 'mkdir po' part above, right?