trouble during shutting down

Asked by Manu on 2014-05-09

Hello,

I have installed marionnet as a non root user and all work fine but I cannot shutdown machine. Even worst : the GUI freeze all my computer if I want to use any menu of marionnet during this endless shutdown process.
The only way is to unplug the machine.
But if I launch marionnet as the root user, I can shutdown machine.

Any ideas will help

Regards

Emmanuel

Question information

Language:
English Edit question
Status:
Answered
For:
marionnet Edit question
Assignee:
No assignee Edit question
Last query:
2014-05-09
Last reply:
2014-06-09
Jean-Vincent Loddo (loddo) said : #1

Hi Emmanuel,

Which distribution and marionnet's version are you using? Anyway, could
you reinstall and try the last (more stable) version of marionnet
calling the script marionnet_from_scratch with the option -m "trunk":

marionnet_from_scratch -m trunk -F -K -P

It would be very interesting for me to know if the "trunk" solves this
kind of problems, because I made an effort specially in this direction
in the last months.
Thank you,
Jean-Vincent

http://www.marionnet.org/wiki/doku.php?id=documentation:marionnet_from_scratch

On Fri, 09 May 2014 16:46:48 -0000, Manu wrote:
> New question #248460 on marionnet:
> https://answers.launchpad.net/marionnet/+question/248460
>
> Hello,
>
> I have installed marionnet as a non root user and all work fine but I
> cannot shutdown machine. Even worst : the GUI freeze all my computer
> if I want to use any menu of marionnet during this endless shutdown
> process.
> The only way is to unplug the machine.
> But if I launch marionnet as the root user, I can shutdown machine.
>
> Any ideas will help
>
> Regards
>
> Emmanuel

NicoD (nicolas-delestre-o) said : #2

HI,

I have the same problem with ubuntu 13.10. I run Marionnet with env command (/usr/bin/env UBUNTU_MENUPROXY=0 /usr/local/bin/marionnet.native). In this case, I can't shutdown machine. I originally installed Marionnet with ''marionnet_from_scratch''.

As you suggest, I try to reinstall Marionnet from trunk version, but I get the following error :

Error: Error on dynamically loaded library: //tmp/marionnet_from_scratch.qWnaFQpX/local/lib/ocaml//stublibs/dllthreads.so: //tmp/marionnet_from_scratch.qWnaFQpX/local/lib/ocaml//stublibs/dllthreads.so: undefined symbol: pthread_sigmask
Command exited with code 2.
FAILURE when building mutexExtra_test.byte
make[2]: *** [mutexExtra_test.byte] Erreur 255
make[2]: quittant le répertoire « /tmp/marionnet_from_scratch.qWnaFQpX/ocamlbricks »
FAILED when building "mutexExtra_test.byte".
make[1]: *** [byte-programs] Erreur 255
make[1]: quittant le répertoire « /tmp/marionnet_from_scratch.qWnaFQpX/ocamlbricks »
FAILURE: could not build bytecode programs.
make: *** [programs] Erreur 255
======
Exiting.
Exiting because of an unexpected error in line 601

Regards.

Can you help with this problem?

Provide an answer of your own, or ask Manu for more information if necessary.

To post a message you must log in.