Problems connecting the router to the real world

Asked by Renzo Venturi on 2013-11-13

Hi,

I use Ubuntu 12.04 LTS and I'm not able to connect a router in Marionnet to the real interface of my computer.
How can I do it?

Renzo Venturi

Question information

Language:
English Edit question
Status:
Answered
For:
marionnet Edit question
Assignee:
No assignee Edit question
Last query:
2013-11-13
Last reply:
2013-11-14
Jean-Vincent Loddo (loddo) said : #1

Hi Renzo,

you have probably an old version of vde2. If you give a look to the
current version of the script `marionnet_from_scratch', you can observe
that the script tries to work around this problem when the host
distribution is precisely Ubuntu 12.04. Here the related section:

---
if are_we_in_ubuntu_12_04 && is_the_packaged_vde2_version_lt_2_3_0; then
   echo "* Warning: Ubuntu 12.04 systems have an old packaged version of
vde2"
   echo " => The problem may be solved installing a vde2 backport
(Virtualization)"
   echo " (see: https://launchpad.net/~pdffs/+archive/precise-virt)"
   echo -n " Shall I install the vde2 backport ([y]/n)? "
   read z
   if [[ $z != n && $z != N ]]; then
     launch_and_log --sudo "Installing vde2 backport for Ubuntu 12.04"
"add-apt-repository -y ppa:pdffs/precise-virt && aptitude update &&
aptitude install -y vde2"
   fi
fi
---

So, the solution for you should be:

add-apt-repository -y ppa:pdffs/precise-virt
aptitude update
aptitude install -y vde2

Best regards,
Jean-Vincent

Le 13/11/2013 19:06, Renzo Venturi a écrit :
> New question #239179 on marionnet:
> https://answers.launchpad.net/marionnet/+question/239179
>
> Hi,
>
> I use Ubuntu 12.04 LTS and I'm not able to connect a router in Marionnet to the real interface of my computer.
> How can I do it?
>
> Renzo Venturi
>
>
>

Can you help with this problem?

Provide an answer of your own, or ask Renzo Venturi for more information if necessary.

To post a message you must log in.