Unable to start marionnet-daemon.byte

Asked by slim ben mahmoud on 2010-12-13

Hi everyone,

in order to start marionnet as described in the wiki, the marionnet-deamon.byte is mandatory for marionnet to work correctly. Unfortunately, I have an error that prevent me to do it. This is the output I obtain :

myterminal:/home/slim# marionnet-daemon.byte
=======================================================
 Welcome to marionnet
 Version : 0.90.3
 Source revision : 316 - 2010-12-03 11:53:52 +0100
 Ocamlbricks revision : 229 - 2010-11-23 10:55:39 +0100

 Built in date 2010-12-09 18:42:33 +0100 on system:

        Linux 2.6.26-2-amd64 #1 SMP Thu Sep 16
        15:56:38 UTC 2010 x86_64 GNU/Linux

 For bug reporting, please get a launchpad account and
 either:
  - report bugs at https://bugs.launchpad.net/marionnet
 or do *all* the following:
  - add yourself to the marionnet-dev team
  - add yourself to the marionnet-dev mailing list
  - write to <email address hidden>
=======================================================
Fatal error: exception Not_found

So I guess that the install was not done adequately or there is some file missing (I used the marionnet from scratch install version).

Thank you for your help (and hope that my request is enough clear).

Regards.

--slim

Question information

Language:
English Edit question
Status:
Solved
For:
marionnet Edit question
Assignee:
No assignee Edit question
Solved by:
slim ben mahmoud
Solved:
2010-12-13
Last query:
2010-12-13
Last reply:
2010-12-13
Luca Saiu (saiu) said : #1

Hello.

Judging from the symptom I strongly suspect this problem has to do with a missing configuration file. Can you try copying the file etc/marionnet.conf into /etc/marionnet.conf, as root? If I'm right the bug is already fixed on Jean-Vincent's computer, but possibly not yet on the trunk and definitely not on a released tarball. Jean-Vincent is busy teaching now, but after he's back he should be able to tell you more.

In the mean time, could you please try re-executing the daemon after setting the environment variable OCAMLRUNPARAM to "b"?
You have to do this (as root):

export OCAMLRUNPARAM=b
marionnet-daemon.byte

That way the error message should mention a source file and line number; we're interested in knowing that in order to confirm.

Your question was perfectly clear. Thanks in advance,

Hi Luca,

thank you for you quick answer.

First, I realized that I have my marionnet.conf configuration file is located at /usr/local/share/marionnet/ directory. Anyway, I copied it into /etc/marionnet.conf but I still have to same error.

As you suggested, I updated the environment variable and this is the new ouput of marionnet-daemon.byte :

beamish:/home/slim# marionnet-daemon.byte
=======================================================
 Welcome to marionnet
 Version : 0.90.3
 Source revision : 316 - 2010-12-03 11:53:52 +0100
 Ocamlbricks revision : 229 - 2010-11-23 10:55:39 +0100

 Built in date 2010-12-09 18:42:33 +0100 on system:

        Linux 2.6.26-2-amd64 #1 SMP Thu Sep 16
        15:56:38 UTC 2010 x86_64 GNU/Linux

 For bug reporting, please get a launchpad account and
 either:
  - report bugs at https://bugs.launchpad.net/marionnet
 or do *all* the following:
  - add yourself to the marionnet-dev team
  - add yourself to the marionnet-dev mailing list
  - write to <email address hidden>
=======================================================
Fatal error: exception Not_found
Raised at file "hashtbl.ml", line 93, characters 19-28
Called from file "marionnet-daemon.ml", line 36, characters 2-46

Thank you again.

Luca Saiu (saiu) said : #3

Oh, sorry. My bad. I wrote /etc/marionnet.conf when I should have written /etc/marionnet/marionnet.conf : you have to make a directory /etc/marionnet for copying the file into. Sorry for the noise.

Well, marionnet-daemon.ml:36 tries to access the configuration file:
 configuration#string "MARIONNET_SOCKET_NAME";;
so now I'm pretty sure the problem is that.

Of course this will be fixed in the next version, and copying marionnet.conf manually will not be needed any longer.

Can you please confirm that this workaround (copying the configuration file into /etc/marionnet/marionnet.conf) work?
Thanks,

Hi Luca,

this is perfect, it works!

Thank you again for you work (on marionnet obviously) and for helping me (and others) to resolve issues related to the tool.

Best regards.

--slim