Use mariabackup 10.2.21 for DB 10.2.6 OK?

Asked by Frank Olsen on 2019-01-25

Dear all,

Hopefully this is the correct forum (I found "Maria Discuss" but you can't ask a question it seems).

I need to setup backups for some databases that are on 10.2.6.

I though using MariaDB Backup instead of Percona xtrabackup, but one the "home page" of "mariabackup" it states that:
- 10.2.7+ : Beta version
- 10.2.10+ : Stable version

Searching everywhere I can't find an answer to the simple question: can I use mariabackup 10.2.21 to safely backup my 10.2.6 databases?
And more generally, in what ways is mariabackup downwards or even upwards compatible?

I tested on VirtualBox, and mariabackup 10.2.21 did backup my one DB/One Table test instance on 10.2.6.
But is it safe in all cases? Can I expect bugs or issues?

For now, I'll also install Percona 2.4.13, but there seems to be issues with that as well, and you need to be careful with various parameters.

So, if anyone has an answer, that would be really helpful, even if it is redirecting me to a more suitable forum!

Best regards,
Frank

Question information

Language:
English Edit question
Status:
Answered
For:
MariaDB Edit question
Assignee:
No assignee Edit question
Last query:
2019-01-25
Last reply:
2019-01-25
Sergei Golubchik (sergii) said : #1

You'd better send an email to <email address hidden>.

MariaDB development was moved to github years ago.
As you can see there were no code changes and no answers here on launchpad for many years.

Can you help with this problem?

Provide an answer of your own, or ask Frank Olsen for more information if necessary.

To post a message you must log in.