How can I install Paint.NET?

Asked by bigj130 on 2007-10-07

GIMP ROCKS!!!

I love gimp, since i started to use Ubuntu, but gimp is
a little confuzing in some parts, but paint.NET is for
little thing, and i want to know on how i can install it!

Thanks!

Question information

Language:
Brazilian Portuguese Edit question
Status:
Solved
For:
Mandriva Edit question
Assignee:
No assignee Edit question
Solved by:
bigj130
Solved:
2008-02-01
Last query:
2008-02-01
Last reply:
2008-01-14
David Portwood (dzportwood) said : #1

paint.NET may run under wine, which you can install via add/remove programs. Then download the paint.NET installer and run it with wine.

Bhavani Shankar (bhavi) said : #2

Hi bjgj130 !:-)

actually , you are now on a linux platform , not windows !.

so all those windows APPS / games are not supposed to work !

so here is a soloution.

There is an app called Wine http://www.winehq.org/

This program is supposed to run your windows Applications on linux !

you can easily download it / install it in a single command in your terminal !

to do that follow those steps:
open your terminal by clicking applications -> Accessories -> Terminal

then when your terminal opens, type in :

sudo apt-get install wine

it should ask for your password, type it in . Notice that it won't show the '*' while you type, but just type in normally ! this is how it works to avoid people from looking over your shoulder !:-)

after the apt gets your program and installs it, you can close the terminal either by typing exit, or clicking the X button !

now it's time to run your Wine !

click on applications -> accessories -> winefile

This will show you something like the old "winfile" !

simply browse to your setup .exe for your pgoram !:-), and do everything like you did it on windows !

btw download paint.net from here:
http://www.getpaint.net/download.html
meanwhile if you have any doubt about this apps' working...,
Please have a look at http://appdb.winehq.org for app compatibility...

Cheers,

br,

Bhavani Shankar.

bigj130 (dunham-jared) said : #3

Bhavani Shankar, thanks for the step by step thing!
That was very helpful!!!

But, its not working....
I installed the Wine from the terminal, but its not in my acesserys thing...

Why?

Jared/ Bigj

David Portwood (dzportwood) said : #4

It may be easier to just right click your paint.NET installer, and click "open with other application" then enter the custom command 'wine'. The install process should start then.

bigj130 (dunham-jared) said : #5

...no its not that, it works and i tryed it on divx player, but after i installed the divx it sayed Error on runtime C://windows//...

But paint.NET, it says i have to get SP2 Pack and i tryed but its confusing....

David Portwood (dzportwood) said : #6

Well, installing divx for windows on Linux is not a good idea,
especially when its readily available in the repos,
"sudo apt-get install avifile-divx-plugin". Linux isnt windows, there
are many programs that do the same thing, I played around with
installing paint.NET, and was only able to get it to install after
installing various software from microsoft first, so 1. you could try
out a program called "winedoors" that assists you in installing these
programs, or 2. Just find an alternative in linux to paint.NET.

bigj130 wrote:
> Question #14711 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/14711
>
> Status: Answered => Open
>
> bigj130 is still having a problem:
> ...no its not that, it works and i tryed it on divx player, but after i
> installed the divx it sayed Error on runtime C://windows//...
>
> But paint.NET, it says i have to get SP2 Pack and i tryed but its
> confusing....
>
>

bigj130 (dunham-jared) said : #7

Well, i cant get on my computer any more, so im on my Wii, ya...

The graghic thingy wont work, and sends me to the termanle, and i have a back up of it, but i forgot the comand!

Sooo..
I was going to re-install Ubuntu, and back up all my programs on a flash drive like i did 18 times in 3 mounths, but i cant find the Ubuntu CD i got from the web site...

The only bad thing about Ubuntu is the install ment and how Window programes dont work with it, and so i have to install wine, and wind windows and other stuff, to try to get some of my windows programes on...

Is there a # i could call for support?

Chris Fox (robotninja) said : #8

Bigj130,

Canonical, the company which supports the Ubuntu project, does provide telephone support contracts but they are primarily aimed at businesses (and with a price tag to match): http://www.ubuntu.com/support/paid

If there are particular applications for Microsoft Windows which you cannot replace with Linux alternatives, you may get better results from either Dual-booting your computer (having both Microsoft Windows and Ubuntu Linux installed on separate partitions of the same PC) or running Microsoft Windows in a Virtual Machine using software such as VMWare or VirtualBox.

https://help.ubuntu.com/community/WindowsDualBoot
https://help.ubuntu.com/community/VirtualMachines

Good luck,

Chris

Michael R. Head (burner) said : #9

There is a port of Paint.NET to mono. It is incomplete, but may be of use to you: http://code.google.com/p/paint-mono/

Michael R. Head (burner) said : #10

You sould be able to get a new official CD from http://shipit.ubuntu.com It'll be the new 7.10 release.

Jozef Mlich (xmlich02) said : #11

i have made package for hardy.
My package works only with hardy herron (not gutsy gibbon). I'm don't know what is the best way to find out dependencies, so i have by hand pushed to "debian\control" all packages libmono-*, but it's not correct solution.
According to http://code.google.com/p/paint-mono/ working paint-mono best with svn version of mono, but in hardy repository is older version, therefore this version of paint-mono can't save image to file.

so if you want to see it yourself u can add my PPA repository to your /etc/apt/sources.list and install..

deb http://ppa.launchpad.net/xmlich02/ubuntu hardy main
sudo apt-get install paint-mono

bigj130 (dunham-jared) said : #12

aww, im using gimp now!
:P

Gimps better!
:D

oren (orengolan) said : #13

Gimp might be better but for some trivial stuff it's not very friendly (drawing a circle in gimp, takes a few non-trivial steps!).

Josef,
I added the line to my repositories and i get this when trying to apt-get install paint-mono:
The following packages have unmet dependencies:
  paint-mono: Depends: mono-tools-locales but it is not installable
E: Broken packages

when i try to install mono-tools-locales i get this:
Package mono-tools-locales is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package mono-tools-locales has no installation candidate

any idea?
(using xubuntu 8.04)

Please try if installing the

mono-tools-gui
and
mono-tools-devel

packages resolve your issue.

Hope this helps

oren (orengolan) said : #15

i installed the packages you mentioned and run sudo make:

yuka@yuka:~/paint-mono-read-only/src$ sudo make
make[1]: Entering directory `/home/yuka/paint-mono-read-only/src'
make[1]: Leaving directory `/home/yuka/paint-mono-read-only/src'
make[1]: Entering directory `/home/yuka/paint-mono-read-only/src/Resources.mui'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/yuka/paint-mono-read-only/src/Resources.mui'
make[1]: Entering directory `/home/yuka/paint-mono-read-only/src/PdnRepair'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/yuka/paint-mono-read-only/src/PdnRepair'
make[1]: Entering directory `/home/yuka/paint-mono-read-only/src/StylusReader'
make pre-all-local-hook prefix=/usr/local
make[2]: Entering directory `/home/yuka/paint-mono-read-only/src/StylusReader'
make[2]: Leaving directory `/home/yuka/paint-mono-read-only/src/StylusReader'
mkdir -p bin/Release/
make RELEASE_AND_PACKAGE_ANY_CPU_BeforeBuild
make[2]: Entering directory `/home/yuka/paint-mono-read-only/src/StylusReader'
make[2]: Leaving directory `/home/yuka/paint-mono-read-only/src/StylusReader'
gmcs -noconfig -codepage:utf8 -warn:4 -optimize+ -debug -define:DEBUG "-define:TRACE" -out:bin/Release/PaintDotNet.StylusReader.dll -target:library './AssemblyInfo.cs' './IStylusReaderHooks.cs' './StylusAsyncPlugin.cs' './StylusReader.cs' -r:System -r:System.Drawing -r:System.Windows.Forms -r:../Microsoft.Ink/Microsoft.Ink.dll
error CS0006: cannot find metadata file `System.Windows.Forms'
Compilation failed: 1 error(s), 0 warnings
make[1]: *** [bin/Release/PaintDotNet.StylusReader.dll] Error 1
make[1]: Leaving directory `/home/yuka/paint-mono-read-only/src/StylusReader'
make: *** [all-recursive] Error 1

oren (orengolan) said : #16

i installed monodevelop, run ./configure, make, make install and it works!
i tried to remove monodevelop, to see if it's needed and got this:

** (/usr/local/lib/paintdotnet/PaintDotNet.exe:15475): WARNING **: The following assembly referenced from /usr/local/lib/paintdotnet/PdnLib.dll could not be loaded:
     Assembly: System.Windows.Forms (assemblyref_index=0)
     Version: 2.0.0.0
     Public Key: b77a5c561934e089
The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/usr/local/lib/paintdotnet).

** (/usr/local/lib/paintdotnet/PaintDotNet.exe:15475): WARNING **: Could not load file or assembly 'System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies.

Unhandled Exception: System.TypeLoadException: Could not load type 'PaintDotNet.Startup' from assembly 'PaintDotNet, Version=3.0.3109.30001, Culture=neutral'.
yuka@yuka:~/paint-mono-read-only/src$ sudo aptitude install monodevelop

oren (orengolan) said : #17

I reinstall monodevelop and it's working again.
i run it from the CLI and get some weird messages, and I wonder if it's normal:

-----HERE------
Got System.Drawing.Rectangle[] get_ClipRectangles() and System.Windows.Forms.Hwnd ObjectFromHandle(IntPtr)
-------Finished--------
SingleInstanceManager.SingleInstaceManager: Not implemented
UI.SetControlRedrawImpl: Not implemented
PORT: HideHorizontalScrollBar missing
SingleInstanceManager.SetWindow: Not implemented
SingleInstanceManager.FilterMessage: Not implemented
Could not get XIM
Resolutions: 0 0

cong06 (cong06) said : #18

on ubuntu, 9.04:
I've installed:
mono
mono-common
mono-devel
monodevelop
mono-tools-gui
mono-tools-devel

And I still get this error:
user@dirac:~/Desktop/paintdotnet-0.1.63$ ./configure
Looking for required packages
Checking for revision...
paintdotnet has been configured with
        prefix = /usr/local
        config = RELEASE_AND_PACKAGE_ANY_CPU

cong06 (cong06) said : #19

so no more ubuntu?