Cannot Reach Administrative Site For List

Asked by cmnorton

I can create a list from the web, but cannot reach administrative site for it (from the web). I know how to create a page if one is needed. I'm just not sure where to hook it in.

http://webapps:8581/mailman/create
Mailing list creation results
You have successfully created the mailing list list1a and notification has been sent to the list owner <email address hidden>. You can now:

    * Visit the list's info page
    * Visit the list's admin page
    * Create another list

Return to the general list overview
Return to the administrative list overview
Delivered by Mailman
version 2.1.12

Question information

Language:
English Edit question
Status:
Solved
For:
GNU Mailman Edit question
Assignee:
No assignee Edit question
Solved by:
cmnorton
Solved:
Last query:
Last reply:
Revision history for this message
Mark Sapiro (msapiro) said :
#1

Assuming the above create URL is correct the listinfo overview page is http://webapps:8581/mailman/listinfo, the admin overview is http://webapps:8581/mailman/admin, the list's listinfo is http://webapps:8581/mailman/listinfo/LISTNAME and the list's admin is http://webapps:8581/mailman/admin/LISTNAME.

Do these URLs work? are these the URLs in the links on the create results?

Revision history for this message
cmnorton (octopusgrabbus) said :
#2
Revision history for this message
Mark Sapiro (msapiro) said :
#3

http://webapps:8581/mailman/listinfo/list1a -- does not work get error

What error?

Revision history for this message
Mark Sapiro (msapiro) said :
#4

Also,

http://webapps:8581/mailman/listinfo/list1a -- does not work get error
http://webapps:8581/mailman/admin/list1a -- Can reach this page

yet in the original ? you say you cannot reach the administrative site. Which is it?

Revision history for this message
cmnorton (octopusgrabbus) said :
#5

I cannot find anything of note in either the mailman or apache logs.
Here's the content of the web page that displays the error.

Bug in Mailman version 2.1.12

We're sorry, we hit a bug!

Please inform the webmaster for this site of this problem. Printing of traceback and other system information has been explicitly inhibited, but the webmaster can find this information in the Mailman error logs.

Revision history for this message
cmnorton (octopusgrabbus) said :
#6

RE:
Mark Sapiro said 4 minutes ago:

Also,

http://webapps:8581/mailman/listinfo/list1a -- does not work get error
http://webapps:8581/mailman/admin/list1a -- Can reach this page

yet in the original ? you say you cannot reach the administrative site. Which is it?

Sorry for the confusion. If I type the administrative password on that page, I get the error, the same one I put up on the most recent response to this questions that starts with Bug in Mailman version...

Revision history for this message
Mark Sapiro (msapiro) said :
#7

Post the full traceback and error message from Mailman's error log.

Revision history for this message
cmnorton (octopusgrabbus) said :
#8

Here's the output of error in logs:
----------------------------------------------
Oct 26 14:08:53 2009 admin(7065): @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
admin(7065): [----- Mailman Version: 2.1.12 -----]
admin(7065): [----- Traceback ------]
admin(7065): Traceback (most recent call last):
admin(7065): File "/usr/local/mailman/scripts/driver", line 112, in run_main
admin(7065): main()
admin(7065): File "/usr/local/mailman/Mailman/Cgi/listinfo.py", line 61, in main
admin(7065): list_listinfo(mlist, language)
admin(7065): File "/usr/local/mailman/Mailman/Cgi/listinfo.py", line 160, in list_listin
fo
admin(7065): replacements = mlist.GetStandardReplacements(lang)
admin(7065): File "/usr/local/mailman/Mailman/HTMLFormatter.py", line 389, in GetStandar
dReplacements
admin(7065): '<mm-archive>' : self.FormatArchiveAnchor(),
admin(7065): File "/usr/local/mailman/Mailman/HTMLFormatter.py", line 326, in FormatArch
iveAnchor
admin(7065): return '<a href="%s">' % self.GetBaseArchiveURL()
admin(7065): File "/usr/local/mailman/Mailman/Archiver/Archiver.py", line 147, in GetBas
eArchiveURL
admin(7065): 'hostname': hostname
admin(7065): KeyError: 'webapps'

Revision history for this message
Mark Sapiro (msapiro) said :
#9

You still have

PUBLIC_ARCHIVE_URL = 'http://%(webapps)s:8581/pipermail/%(listname)s'

in mm_cfg.py. You didn't change it to

PUBLIC_ARCHIVE_URL = 'http://%(hostname)s:8581/pipermail/%(listname)s'

As I said and you said you did in comments at https://answers.launchpad.net/mailman/+question/86688

Revision history for this message
cmnorton (octopusgrabbus) said :
#10

Mea culpa. I thought that hostname was a substitute for the real hostname. I'll go try that and get back to you.

Revision history for this message
cmnorton (octopusgrabbus) said :
#11

Sorry again for the cockpit error. Problem fixed.