You don't have permission to access /pipermail/ on this server.

Asked by kibirango moses

You don't have permission to access /pipermail/on this server. What are the right permissions to be used?

Question information

English Edit question
GNU Mailman Edit question
No assignee Edit question
Solved by:
Mark Sapiro
Last query:
Last reply:
Revision history for this message
Best Mark Sapiro (msapiro) said :

In Apache:

Alias /pipermail/ /path/to/archives/public/
<Directory "/path/to/archives/public">
    Options +FollowSymLinks
    Order allow,deny
    Allow from all

$ ls -ld archives/p*
drwxrws--x 18 root mailman 4096 Feb 28 06:47 archives/private
drwxrwsr-x 2 root mailman 4096 Jan 12 17:02 archives/public

The owner (root) is not important. the group is Mailman's group and may or may not be 'mailman' (e.g. on a debian/ubuntu package install, it is 'list')

If archives/private is not o+x, then the owner of archives/private must be the web server user whatever that is - i.e. the web server user must be able to search in archives/private.

Revision history for this message
kibirango moses (kibirango-moses) said :

Thanks Mark Sapiro, that solved my question.