tc4400 stylus input backward

Asked by aricks

I'm running xubuntu 11.10 on a HP tc4400 and I'm trying to get magick rotate to work. It works fine for normal and inverted configurations but in left and right mode the stylus and mouse input are backwards, i.e. moving the mouse down causes the cursor to move up and moving the mouse to the left causes the cursor to go to the right. I messed with the script to change ccw to cw but couldn't get that to work, also tried this with BIOS hinge switched value reversed set to true and false but nothing seems to fix this problem.

Question information

English Edit question
Magick Rotation Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Favux (favux-is) said :

Hi aricks

There is a bug in the xf86-input-wacom versions used in Natty and Oneiric that causes cw and ccw to be swapped. It is fixed by xf86-input-wacom-0.12.1. Rather than try to work around the bug in Magick we encourage you to update your xf86-input-wacom. There is a FAQ for that.

Revision history for this message
aricks (tenhigh) said :

Thanks. Part of the problem was with xournal, if I open xournal then rotate the input is messed up however if I rotate the open xournal it is fine. But if I go to normal the input to xournal is messed up. Just took a bit of hair pulling and things working sometimes and then not before I realised this.