Green icon missing in Natty?

Asked by es128

I am a noob using a Dell XT2 running Ubuntu 11.04. Magick-rotation is installed and works (sort of), but I've never been able to get the green icon in the tray. When launching, the popup comes up to say Touch Status: On, but without the icon I don't have any way to change settings.

Some other details:
The rafi wmi patch didn't seem to work for me, but one of the other ones that Auythia posted did. In xxd the rotation event shows two lines of output instead of the three lines that I saw in the forums.

Also, even though the screen rotation works, touch and pen rotation does not. They both work, but the cursor moves as if I was on normal screen orientation (i.e. I move left, cursor moves up). I'm sure I'll be able to figure out how to fix that, just haven't gotten that far yet.

Question information

Language:
English Edit question
Status:
Solved
For:
Magick Rotation Edit question
Assignee:
No assignee Edit question
Solved by:
Nphyx
Solved:
Last query:
Last reply:
Revision history for this message
cm-t 🦄🏂🌈🎵 (cm-t) said :
#1

Hi Elan,

I'm using natty on a HP tm2 (2190sf) and this bug doesn't affect magick-rotation only. It's more like tray system doesn't exist (yet?) in natty.
I agree that it should be great if we can launch Magick Rotation GUI config by an other way than tray.

You can logout, and choose Ubuntu Classic to log on with gnome-panel with the magick-rotation icon, there you can edit settings before log out back to ubuntu (unity)

--

for the cursor this affect myself too:

normal/inverted rotate are OK
right/left → screen/mouse OK, pen/finger are inverted as a central symmetry

(
Natty devlopment branch:
2.6.38-7-generic #39-Ubuntu SMP Fri Mar 25 21:24:57 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
)

Librement.

Revision history for this message
Best Nphyx (nphyxx) said :
#2

An alternative to this is to whitelist the magick-rotation app so that it's allowed to use the system tray. Easiest way is to grab this script here: http://www.fewt.com/2011/03/whitelist-utility-script-to-allow-apps.html

Then just open up a terminal, navigate to where you saved the list, and type 'whitelist magick-rotation'. You may have to restart magick-rotation for it to show up.

Revision history for this message
es128 (es128) said :
#3

Thanks Nphyx, that solved my question.

Revision history for this message
es128 (es128) said :
#4

Just as a quick note - I had to log out and log back in for the whitelist to take effect (not just restart magick-rotation)