cannot install magentoerpconnect_bundle and so on

Asked by chocolee on 2013-04-05

when I install the follow modules in openERP ,the error occured! Please help me to solve this proble ,Thank you very much .
1.magentoerpconnect_bundle
2.magentoerpconnect_bundle_split
3.and other magentoerpconnect related modules

Error:
Traceback (most recent call last):
  File "/usr/local/openerp/openerp-server/openerp/osv/osv.py", line 121, in wrapper
    return f(self, dbname, *args, **kwargs)
  File "/usr/local/openerp/openerp-server/openerp/osv/osv.py", line 176, in execute
    res = self.execute_cr(cr, uid, obj, method, *args, **kw)
  File "/usr/local/openerp/openerp-server/openerp/osv/osv.py", line 164, in execute_cr
    return getattr(object, method)(cr, uid, *args, **kw)
  File "/usr/local/openerp/openerp-server/openerp/addons/base/module/wizard/base_module_upgrade.py", line 101, in upgrade_module
    _db, pool = pooler.restart_pool(cr.dbname, update_module=True)
  File "/usr/local/openerp/openerp-server/openerp/pooler.py", line 39, in restart_pool
    registry = RegistryManager.new(db_name, force_demo, status, update_module, True)
  File "/usr/local/openerp/openerp-server/openerp/modules/registry.py", line 202, in new
    openerp.modules.load_modules(registry.db, force_demo, status, update_module)
  File "/usr/local/openerp/openerp-server/openerp/modules/loading.py", line 338, in load_modules
    processed = load_marked_modules(cr, graph, states_to_load, force, status, report, loaded_modules)
  File "/usr/local/openerp/openerp-server/openerp/modules/loading.py", line 253, in load_marked_modules
    loaded, processed = load_module_graph(cr, graph, progressdict, report=report, skip_modules=loaded_modules)
  File "/usr/local/openerp/openerp-server/openerp/modules/loading.py", line 192, in load_module_graph
    load_update_xml(module_name, idref, mode)
  File "/usr/local/openerp/openerp-server/openerp/modules/loading.py", line 90, in <lambda>
    load_update_xml = lambda *args: _load_data(cr, *args, kind='update_xml')
  File "/usr/local/openerp/openerp-server/openerp/modules/loading.py", line 132, in _load_data
    tools.convert_csv_import(cr, module_name, pathname, fp.read(), idref, mode, noupdate)
  File "/usr/local/openerp/openerp-server/openerp/tools/convert.py", line 970, in convert_csv_import
    result, rows, warning_msg, dummy = pool.get(model).import_data(cr, uid, fields, datas,mode, module, noupdate, filename=fname_partial)
  File "/usr/local/openerp/openerp-server/openerp/osv/orm.py", line 1412, in import_data
    process_liness(self, datas, [], current_module, self._name, fields_def, position=position)
  File "/usr/local/openerp/openerp-server/openerp/osv/orm.py", line 1341, in process_liness
    field_type = fields_def[field_name]['type']
KeyError: 'type_id'

Expect your help!!!

Question information

Language:
English Edit question
Status:
Solved
For:
Magento OpenERP Connector Edit question
Assignee:
No assignee Edit question
Solved by:
chocolee
Solved:
2013-04-16
Last query:
2013-04-16
Last reply:
Florent THOMAS (mailinglist) said : #1

Hy,

Could you precise the release of your OpenERP and the source you used for the magento apps.
Obviously, it doesn't seems to be available for the 7.x releases.

regards

chocolee (326209215-q) said : #2

Thank you , I download another package solved this problem .bzr branch lp:magentoerpconnect/magento-module-oerp6.x-stable