Invalid API path

Asked by Vivek poddar on 2012-06-15

Hi,

I have installed the magento-extension as well as OpenERP side modules. I installed the core modules in OpenERP and I was also able import all the product categories, but the problem started when I wanted to do "Synchronize Referential Settings". I am getting: <Fault 3: 'Invalid api path.'>. I am bit stuck here because it seems that all the further settings depends on this step.

Question information

Language:
English Edit question
Status:
Solved
For:
Magento OpenERP Connector Edit question
Assignee:
No assignee Edit question
Solved by:
Vivek poddar
Solved:
2012-06-16
Last query:
2012-06-16
Last reply:
Vivek poddar (vivekimsit) said : #1

One more thing! when I tried manually to connect to the resources: ol_websites.list and ol_stores.list, I get the same error.

Vivek poddar (vivekimsit) said : #2

Hi,

Now I this is really frustating. For a single project there a n numbers of the versions, code repository and everything is so scattered. To use Magento I simply used this key which I got from: http://www.magentocommerce.com/magento-connect/open-erp-connector-by-openlabs.html and it not installs properly! some config files were missing for which I spend hours to search what is going on. Guys please remove all the code which are absolete now.

     Cheers to me! As I solved the issue myself. :)

JOVICYR (jovicyr) said : #3

Hi Vivek,

I installed the connector :
https://code.launchpad.net/~magentoerpconnect-core-editors/magentoerpconnect/openerp6.1-module

And proceed to importation.
Steps 1 to 5 work
But I got an error on step 6 importation products : the same as yours :
Fault: <Fault 3: 'Invalid api path.'>

Could you tell me how you fix it ?
Thanks a lot for your kind answer,

Regards,
Jovi

Brett Lehrer (brett-lehrer) said : #4

So how did you solve it? I'm seeing the exact same problem as JOVICYR on the exact same step (when importing products).

Any help would be much appreciated.

Brett

JOVICYR (jovicyr) said : #5

Hi,

I downloaded latest release, both of magento module and OpenERP dependencies.
And, check that no zip file still exist in addons folder.

Brett Lehrer (brett-lehrer) said : #6

Ahh, I made the mistake of using the Magento module from the Magento Connect website (which hasn't been updated since February). Downloading the trunk of the module and installing it manually in Magento solved that problem, thank you.