magentoerpconnect install error

Asked by Raffi

Anyone know why when installing magentoerpconnect from trunk and openerp6 branch I get the following error?

ValueError: No references to magentoerpconnect.magento1324

Only reference on the internet I can find is a pastebin with the same error.


Full trace below:

Traceback (most recent call last):
  File "/opt/openerp/server/bin/", line 489, in dispatch
    result = ExportService.getService(service_name).dispatch(method, auth, params)
  File "/opt/openerp/server/bin/service/", line 599, in dispatch
    res = fn(db, uid, *params)
  File "/opt/openerp/server/bin/osv/", line 122, in wrapper
    return f(self, dbname, *args, **kwargs)
  File "/opt/openerp/server/bin/osv/", line 176, in execute
    res = self.execute_cr(cr, uid, obj, method, *args, **kw)
  File "/opt/openerp/server/bin/osv/", line 167, in execute_cr
    return getattr(object, method)(cr, uid, *args, **kw)
  File "/opt/openerp/server/bin/addons/base/module/wizard/", line 98, in upgrade_module
    _db, pool = pooler.restart_pool(cr.dbname, update_module=True)
  File "/opt/openerp/server/bin/", line 60, in restart_pool
    return get_db_and_pool(db_name, force_demo, status, update_module=update_module)
  File "/opt/openerp/server/bin/", line 39, in get_db_and_pool
    addons.load_modules(db, force_demo, status, update_module)
  File "/opt/openerp/server/bin/addons/", line 883, in load_modules
    processed_modules.extend(load_module_graph(cr, graph, status, report=report, skip_modules=processed_modules))
  File "/opt/openerp/server/bin/addons/", line 748, in load_module_graph
    load_init_update_xml(cr, m, idref, mode, kind)
  File "/opt/openerp/server/bin/addons/", line 635, in load_init_update_xml
    tools.convert_csv_import(cr, m, os.path.basename(filename),, idref, mode=mode, noupdate=noupdate)
  File "/opt/openerp/server/bin/tools/", line 947, in convert_csv_import
    result, rows, warning_msg, dummy = pool.get(model).import_data(cr, uid, fields, datas,mode, module, noupdate, filename=fname_partial)
  File "/opt/openerp/server/bin/osv/", line 870, in import_data
    process_liness(self, datas, [], current_module, self._name, fields_def, position=position)
  File "/opt/openerp/server/bin/osv/", line 820, in process_liness
    res = _get_id(relation, line[i], current_module, mode)
  File "/opt/openerp/server/bin/osv/", line 737, in _get_id
    raise ValueError('No references to %s.%s' % (module, xml_id))
ValueError: No references to magentoerpconnect.magento1324

Question information

English Edit question
Magento OpenERP Connector Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Raffi (raffij) said :

Went back to it and it installed ok.

Revision history for this message
Jamie McKenzie (32-jamie) said :

I restarted the openerp-server and tried applying module upgrades and it installed fine. I find sometimes that it is best to get the dependancies installed first manually.