Guide to Install Connector with OpenERP6 and Magento 1.5

Asked by Jorge Mendes on 2011-06-16

Here is a guide I've created (mixed with the already existing for OpenERP 5 and Magento 1.3) on how to install this connector using Open ERP 6 and Magento 1.5

I'm sorry if this is not the appropriate place to put this information, hope this can be usefull

MAGENTO 1.5

Step 1: Open System > Magento Connect > Magento Connect Manager
Step 2: In settings set preferred state as Alpha (The connector is alpha)
Step 3: Paste extension key in box and click install (Extension Key: http://connect20.magentocommerce.com/community/Openlabs_OpenERPConnector)
Step 4: Create a web services user from System > Web Service > User with a role with access to all

OpenERP6:

Dependencies
product (this should already be installed)
base_external_referentials
base_sale_multichannels (not sure if you need this)
product_images_olbs
product_links
product_m2mcategories

Use Baazar Explorer to get modules from
http://bazaar.launchpad.net/~openerp-commiter/openobject-addons/extra-6.0/

zip the folders you will need (check above dependencies) and import them into OpenERP

Step 0: Ensure that you have atleast 1 Product category in your system or create one. (Required)
Step 1: Use Baazar Explorer to get connector module available at bzr branch http://bazaar.launchpad.net/~openlabs-akretion-consortium/magentoerpconnect/magentoerpconnect-v6/)
zip the magentoerpconnect folder and import it in OpenERP (you might need the other folder also depending on what you are trying to achieve)

Step 2: Goto Magento Connection > Core Settings > Magento Instances (these next 4 step have to be done via GTK Client, it doesn't work for me with the Web Client, I can't put the name of the instance)
Step 3: Create a new instance by clicking new
Step 4: Give the connection a name (eg. My local magento)
Step 5: Referential Type (Only 1.3.2.4 is available now)
Step 6: Location: Your magento URL eg (http://127.0.0.1/magento DO NOT USE localhost it won't work) & Default Product category (Magento allows products without category and those will be classified here)
Step 7: Click on Reload Referential Mapping Templates (from here you can do it in the Web Client)
Step 8: Enter API Username and password defined in step 4 of magento configuration
Step 9: Click on Synchronise Referential Settings

If you get the following error
Fault: <Fault 3: 'Invalid api path.'>
Follow this solution
https://bugs.launchpad.net/magentoerpconnect/+bug/610450 (Post #5 by Almanar)

Question information

Language:
English Edit question
Status:
Solved
For:
Magento OpenERP Connector Edit question
Assignee:
No assignee Edit question
Solved by:
Jorge Mendes
Solved:
2011-06-16
Last query:
2011-06-16
Last reply:
Jorge Mendes (jmendes-o) said : #1

If you have any problems I will try to assist you, but this is my first time using this any of this 3 pieces of software

ntrubert-cobweb (ntrubert) said : #2

Thank for this howto.

Do you know where we can found "product_links" module ?
Others are in launchpad or extra-addons but no trace of this one.

ntrubert-cobweb (ntrubert) said : #3

Sorry my v6 extra-addons was not up to date.

product_links is not in a trunk only to branch you mention.

http://bazaar.launchpad.net/~openerp-commiter/openobject-addons/extra-6.0/

Thanks again.

Jorge Mendes (jmendes-o) said : #4

I was about to reply, but I see you already manage
Good luck, and I hope you don't get different results :)

hi,
Thanks for this howTo, it was very usefull for me.
However, I've an error when I try to export catalog. I have the error below :

" No external id found, are you sure that the referential are syncronized? Please contact your administrator. (more information in magentoerpconnect/sale.py)"

And I see in Magento that the export was done successfully for products but not for categories.
wha'ts the matter ?

best,

Now, I can export product without error :

* Ventes > Produits > Produits menu
* I create a new product
* I clic on `Export product`
* I choose a store
* clic on Export product
I can see the product is added in Magento, at the right category.

However, when I clic on `Export Stock` or `Export Product And Stock`, I have the same error.
I think we should look at warehouse references.

your help will be greatly appreciated .

José Candelas (jcandelas) said : #7

hi everybody,

just in las last (Step 9: Click on Synchronise Referential Settings) step I get this error:

ProtocolError: <ProtocolError for 127.0.0.1/magento/index.php/api/xmlrpc/: 404 Not Found>

Maybe I don't put this fields (API Username and password, step 8) on the correct place, I place them on Authentication tab above "Core Components"

your help will be greatly appreciated.

Jorge Mendes (jmendes-o) said : #8

Hello José,

I think your problem it's not the credentials (i.e. username and password) something seems to be wrong with the URL for magento, that's why you are getting the 404 (which means that the URL doesn't exist)

I noticed there is not http:// before the URL, maybe it's removed when you see the error message, but it might be worth while to have a look at that

Another suggestion is that if you installed Magento in a port other then 80, then you need to add the port like the following 127.0.0.1:8080 (assuming the port you installed on was 8080)

On another note: Amath Sow, sorry I didn't reply, it skipped me, but I'm not sure what to do in that scenario...

Arno Nebauer (arno-shopnix) said : #9

Hi all,

Tried to follow the above instructions and got the first problem at Magento 1.5, step 3:

Invalid package identifier provided: http://connect20.magentocommerce.com/community/Openlabs_OpenERPConnector

Any hints?

Landis (larnold) said : #10

I have been implementing today..

I have found the easiest way to get all the required modules in is from the aps.openerp.com Site.
On the right side the "download" links (very small) will allow you to get a zip file out.

I have been unable to do this off the launchpad.net site. BZR works but I was not able to get OpenERP to recongnize Folders imported straight into ADDONS. Thus the Zips were the fix on the aps.openerp.com site.

I am having some timeout errors now so I expect I need to make more RAM available to both systems.

Exciting if this can work... Seems it will.

Landis (larnold) said : #11

Does the same process work with 1.6.1 Magento? I can't get it to take.

Todd Palmieri (todd-palmieri) said : #12

This comes back as a bad link http://bazaar.launchpad.net/~openlabs-akretion-consortium/magentoerpconnect/magentoerpconnect-v6/

How do I get the connector?

Thanks!