Magento Instances Crashes After Install

Asked by Todd Southwick on 2011-06-09

Here is the traceback. This is a clean install on new database with all new modules. (no trunk versions, just the new v6 versions fromn launchpad. I have re-installed several times. I have no idea the problem.

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/netsvc.py", line 489, in dispatch
    result = ExportService.getService(service_name).dispatch(method, auth, params)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/service/web_services.py", line 599, in dispatch
    res = fn(db, uid, *params)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/addons/audittrail/audittrail.py", line 511, in execute
    res = my_fct(db, uid, model, method, *args)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/addons/audittrail/audittrail.py", line 489, in my_fct
    return fct_src(db, uid, model, method, *args)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/osv/osv.py", line 122, in wrapper
    return f(self, dbname, *args, **kwargs)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/osv/osv.py", line 176, in execute
    res = self.execute_cr(cr, uid, obj, method, *args, **kw)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/osv/osv.py", line 167, in execute_cr
    return getattr(object, method)(cr, uid, *args, **kw)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/osv/orm.py", line 1628, in fields_view_get
    xml = self.__get_default_search_view(cr, user, context)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/osv/orm.py", line 1391, in __get_default_search_view
    form_view = self.fields_view_get(cr, uid, False, 'form', context=context)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/osv/orm.py", line 1598, in fields_view_get
    result['arch'] = _inherit_apply_rec(inherit_result, sql_res[3])
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/osv/orm.py", line 1593, in _inherit_apply_rec
    result = _inherit_apply(result, inherit, id)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/osv/orm.py", line 1535, in _inherit_apply
    raise_view_error("Element '%s' not found in parent view '%%(parent_xml_id)s'" % tag, inherit_id)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/osv/orm.py", line 1449, in raise_view_error
    'model': self._name, })
AttributeError: View definition error for inherited view 'magentoerpconnect.magerp_instances_form' on 'external.referential' model: Element '<xpath expr="/form/group[2]/notebook">' not found in parent view 'base_external_referentials.external_referential_form_view'

Question information

Language:
English Edit question
Status:
Solved
For:
Magento OpenERP Connector Edit question
Assignee:
No assignee Edit question
Solved by:
Todd Southwick
Solved:
2011-06-09
Last query:
2011-06-09
Last reply:
Todd Southwick (tsouthwi) said : #1

Ok for all those who need to fix this problem. Download the correct modules here:

magentoeroconnect:
http://bazaar.launchpad.net/~openlabs-akretion-consortium/magentoerpconnect/magentoerpconnect-v6/files

and get the following modules fresh for v6 or you will be screwed don't dowload the zip files they are v5 or not updated.

base_external_referentials
base_sale_multichannels
product_images_olbs
product_links
product_m2mcategories

download them here (no where else there is a lot of old code out there. Download them from launchpad only.
http://bazaar.launchpad.net/~openerp-commiter/openobject-addons/extra-6.0/files

yacine boutayeb (y-boutayeb) said : #2

Hi,

I had the same error when iam trying to install this connector, could you help me please

Todd Southwick (tsouthwi) said : #3

Did you download all fresh code from launchpad?

yacine boutayeb (y-boutayeb) said : #4

Thanks for you reply!

Yes all modules seem to be good, but iam not sure for the magentoerpconnect module because this link don't work http://bazaar.launchpad.net/~openlabs-akretion-consortium/magentoerpconnect/magentoerpconnect-v6/files

Thks

Todd Southwick (tsouthwi) said : #6

delete the old module and all the dependent modules in openerp. then reinstall all the modules on a fresh database and it should work.

yacine boutayeb (y-boutayeb) said : #7

When i trying to install base_external_referentials modules, I've got this error:
Error occurred while validating the field(s) res_model,src_model: Invalid model name in the action definition.
Any idea ?

Thks a lot

Todd Southwick (tsouthwi) said : #8

If I remember this happens if there is data in the database. Did you install with sample data? I would dump your database, create a new clean one. Then only install the accounting module and then your dependant modules for openerp connector. Otherwise I am stumped with you. Best I can say is email me at tsouthwiAThotmailDOTCOM and I will send you a set of files I know already works.

Landis (larnold) said : #9

How do you Download from Launchpad and get the modules into Zip Format then onto the Server?

I have BZR's onto my server but the Server does not recongize the modules. Only way I can get modules to load is from aps.openerp.com.

Would like to be using BZR as it seems lots of fixes are here and not elsewhere. That said, perhaps aps.openerp.com is up to date.