Products import does not match categories - Openerp6-module

Asked by Hillebrand Dalstra on 2011-01-13

During the installation of the Openerp6-module and all it dependencies, two default product categories are created (Service and All Products).
When configuring the settings of the connector a default category is required to be set in the Core Settings. I created a new default category called "Products without category" and set up the connector.

These are the steps:

1. Reload referential map settings
2. Synchronize Referential settings

Then I use the buttons in the connector in the presented sequence.

1) import Customer Groups
2) import product categories
3) import product attributes sets
4) import attribute groups
5) import product attributes
6) import products

Everything seems to be imported without a problem.

Except I have two problems:

First issue:

Something strange occurs when the product categories from Magento are imported. The "Root Catalog" suddenly gets a new parent category called "UNDEFINED".

Magento's original categories:

Root Catalog/
Root Catalog/CategoryX
Root Catalog/CategoryY

OpenERP imported catalog

UNDEFINED/Root Catalog/
UNDEFINED/Root Catalog/CategoryX
UNDEFINED/Root Catalog/CategoryY

Second issue:

The next problem occurs when all products from magento are imported to the 'All products" category and not in the category structure that was imported from Magento.
Manual assigning product categories in the 'Extra Categories tab" and exporting the catalog to Magento doesn't work neither.

I'm using the following setup:

- Openerp-server-6.0.0-rc2

- Openerp6-module ref. version: 381

Openerp6-module dependencies (extra-trunk ref. version:5158)
- Product_m2mcategories
- Base_sale_multichannels
- Base_external_referentials
- Product_images_olbs

- Magento 1.4.2.0 with magento-module ref. version 24.

A similar question was posted here: https://answers.launchpad.net/magentoerpconnect/+question/89832

Any help would be greatly appreciated.

H

Question information

Language:
English Edit question
Status:
Solved
For:
Magento OpenERP Connector Edit question
Assignee:
No assignee Edit question
Solved by:
Hillebrand Dalstra
Solved:
2011-02-21
Last query:
2011-02-21
Last reply:

The 'UNDEFINED' issue I reported earlier seems to be resolve in the latest version of the connector (v. 389) in combination with OpenERP v. 6.0.

Therefore I will close this question.

picou (6-contact-pointpc-net) said : #2

If I look at the magento connect module details as of today, the last download indicates Compatibility:1.3.
and bazar magentoerpconnect_generic indicates revision 301.
Could you please indicate where I can get all the latest revisions you seem to be refuring to?
Thanks for leaving the detailed links.

picou (6-contact-pointpc-net) said : #4

Ok thanks, my system is still on openerp v5.0.15 that explains the old revisions.
I really think these links will help others.

photo7 (photo7) said : #5

I'm still having the same problem with the UNDEFINED categories and product import not matching the imported categories - exactly as it was described it the top post.

I have tried v6.01 and trunk and 6.0 branch with the latest connector - nothing works, so I'm assuming that this problem is data driven and depend on Magento configuration (we run 1.4.2.0)

In my Magento setup I have multiply stores with products shared between them, but in different categories. I also have default store that is completely empty - I don't know if this is what creating this problem.

I just tested the connector with v. 6.0.1 and latest 6.0 branch against Magento 1.4.2 with demo data.
Got the same issue that I had before. So reopening the question...

photo7 (photo7) said : #7

Still same issue here as well...

I just checked the same configuration:

1. OpenErp 6.01
2. Latest v6 magento connector
3. Fresh Magento 1.4.2.0 install with demo data

and I have the same problem again as described here: UNDEFINED top category and non of the products allocated to any categories. I checked the "product_categ_rel" table and it is completely empty in my test database after magento import.

May be we should open a bug for this?

Our problem is linked to this bug report: https://bugs.launchpad.net/bugs/711702

picou (6-contact-pointpc-net) said : #9

I had this exact problem with
open erp V5.015
Latest V5 magento connector
fresh install of magento 1.3.3.0

photo7 provided a patch for this problem. Check bug report (https://bugs.launchpad.net/bugs/711702) to solve this problem.
Picou let us know if this also solve your problem for magento 1.3.3.0.