products are not updated/exported to magento

Asked by jehan on 2010-09-16

Hi,

I use magentoerpconnect rev. 341 and installed the magento plugin via magento connect.
The magento shop contains three categories and two products in one of the categories.

I imported all categories and products to openerp and modified a descriptional text of one of the products. Now if I export the catalog the modified product (descriptional text) gets not updated on magento.

I opened the openerp-server log and saw several lines like this:
INFO:ext synchro:Updated in External Ref product.category from OpenERP with external_id 2 and OpenERP id 2 successfully
but no entry in the log signals that product.product was updated.

Next I created a new category in openerp and exported it to magento wich works fine. After that I created a new product in openerp and assigned it to the new category - if try to export the new product it gets silently ignored by openerp and only product.categroy is exported to magento.

I searched the web and read several answers to similar problems but doesn't manage to get products in openerp exported to magento. I also saw that people ask more complex questions about magentoerpconnect wich lead me to the assumption that they have the bridge up and running and that my problems exporting/updating a product are marginal and are maybe caused by a stupid misconfiguration from a beginner in magentoerpconnect.

My question is: what have I missed in updating/exporting a product from erp to magento?

Question information

Language:
English Edit question
Status:
Solved
For:
Magento OpenERP Connector Edit question
Assignee:
No assignee Edit question
Solved by:
jehan
Solved:
2010-09-21
Last query:
2010-09-21
Last reply:
2010-09-20
ntrubert-cobweb (ntrubert) said : #1

By exporting product you mean "Export Catalog" ?

For me all my product is created on magento side import to openerp and after I'm able to export some data form openerp to magento.
I do not experiment yet a new openerp product exported by create method.

May be you can try to create a new product on magento side with "Magento SKU" that you gave it at your new openerp product. Amd try to export again.

jehan (jens-e-hansen) said : #2

Yes I meant "Export Catalog".
Unfortunately importing a product from magento and exporting it again with a modified description doesn't work for me also.

Please could you tell me what versions of magento, openerp and magentoerpconnect you use?

I use the latest stable of openerp, revision 341 of magentoerpconnect and magento 1.4.x-devel-71052.
I'm unsure if I should better use magento version 1.3.2.4.

thank you very much

ntrubert-cobweb (ntrubert) said : #3

I'm working on :
Magento ver. 1.4.1.1
Openerp 5.0.14
I do not work with the last release of the module 341 but with this branch ~openlabs-akretion-consortium/magentoerpconnect/improved_discount_n_address + some modifications.

jehan (jens-e-hansen) said : #4

Ok - thank you for your reply.
I forgot to update the openerp modules also.
Exporting products works like expected now.

Gabriel Ruiz (gruiz) said : #5

Hi all

I have the same problem: I can import products from Magento through "Import products", but I cannot export them from OpenERP to Magento.
I'm working on:
Magento ver. 1.4.1.1
Openerp 5.0.12
magentoerpconnect branch improved_discount_n_address

If I try to export them with "Export Catalog" y get an error message saying that there is an error in the formulary and I have to corret the red fields, but there are none of them.

I suppose it could be a missconfiguration problem.
Is there any trigger that has to be set up in order to run the export periodically?

Jehan, which modules did you have to update in order to get it working?
The export has to be done manually through "Export Catalog" or will be done automatically when a new product is created?

Thanks in advance.

jehan (jens-e-hansen) said : #6

Hi,

I'm sorry that I completely missed your message until now.
Because I'm learning magentoerpconnect myself I only can give you vague hints:

red fields
You should check all fields in every tab in the form with the button to "Export Catalog". Also you should investigate every field in every tab of the products you try to export.

export periodically
In openerp GTK-client go to Administration -> Configuration -> Scheduler -> Sheduled Actions. Here you can find an action named "Magento Export Catalog" which isn't active. I haven't tried it but for me it looks like a good candidate ...

updated modules
I forgot to update the openerp python magentoerpconnect module, precisely I forgot to link this module into the openerp addons directory and I used an outdated module. Currently I'm on oerp server rev. 2123, oerp addons rev. 2855, oerp extra-addons rev. 4527 and magentoerpconnect rev. 341.

I hope I could help and again sorry for the late reply.

Hi,
I also have an error when I try to export a catalog to Magento. Even if I create a category without product.
How did you exported a category? have you created a specific magento instance?

best,