Authorization Required

Asked by ntrubert-cobweb

I got this error when I Try to Synchronize Referential Settings:

ProtocolError: <ProtocolError for "my_url"/index.php/api/xmlrpc/: 401 Authorization Required>

I set for the authentication the following parameters:
User Name : Same user define to magento to web-service with roles with all resource access
Password : "Api Key" of the magento user.

What am I doing wrong ?

What can I do to trace?

Question information

English Edit question
Magento OpenERP Connector Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
ntrubert-cobweb (ntrubert) said :

Dear all,

I'm coming back on this behavior, I always got same authorization error
ProtocolError: <ProtocolError for ...../index.php/api/xmlrpc/: 401 Authorization Required>

Web service does not answer on my prod server.
With my staging server I do not have this issue even if I call same Magento instance.

Server log:
[2010-05-17 16:03:24,085] INFO: Magento Connection:Attempting connection with Settings:http:/.................../index.php/api/xmlrpc/,<user>,<pass>
[2010-05-17 16:03:39,087] WARNING:Magento Connection:Webse
[2010-05-17 16:03:55,095] WARNING:Magento Connection:Webse
[2010-05-17 16:04:13,103] WARNING:Magento Connection:Webse
[2010-05-17 16:04:34,208] ERROR:Magento Connection:[01]:

Staging server log :
[2010-05-17 15:42:53,600] INFO:Magento Connection:Attempting connection with Settings:http://........../index.php/api/xmlrpc/<user>,<pass>
[2010-05-17 15:42:54,531] INFO:Magento Connection:Login Successful

I do not have firewall, so how can I get more information ?

My conf:
openerp-server-5.0.9 on debian lenny linux-vserver
Magento ver.

Revision history for this message
ntrubert-cobweb (ntrubert) said :

Sorry on magento side there is a .htacess I added an "Allow from" for my openerp server

And now it works.