Indirect detection spectrum gives zeros

Asked by Sanket Doshi

define darkmatter chi1 chi1~
define coannihilator chi2 chi2~
define nnbsm = ne1 nm1 nt1 ne1~ nm1~ nt1~
define nu = ve vm vt ve~ vm~ vt~
define sm = nu g a u c t s b d u~ c~ t~ s~ b~ d~ z w+ w- h e- mu- ta- e+ mu+ ta+
generate relic_density
#generate indirect_detection
add indirect_detection nu nbsm, nbsm > sm sm sm
output try21
launch try21

In the model, we have DM DM -> neutrino + strongly coupled particle. The strongly coupled particle likely decays to muons, electrons, neutrinos, and jets and we want this to be done in Pythia. The final goal is to get the energy spectra for electron/positron and photons.

When I do the above, I get the error

"PhysicsObjectError : process is not a valid property for this object: DecayChainAmplitude

            Valid property are ['amplitudes', 'decay_chains']"

in the output step or the launch step if I do that directly.

When I remove the ", ncomp > sm sm sm" part, the code runs okay and gives me 0 values in the energy spectra.

Please help, I am unable to figure out why this is happening. The strongly coupled particle mixes with the standard model neutrino and has a chi chi N N effective vertex with the DM fermion chi.


Question information

Revision history for this message
Daniele Massaro (dmassaro) said :

Hi Sanket Doshi,

we were aware about a bug which prevented to accept the decay syntax.
For that we have a patch, which you can find linked to the bug report associated to this question.
To use the patch, you first need to look for the "related branches" in the page of the bug report, then download the branch (which is called decay_syntax) with bazaar and substitute the content of the directory <MadGraph_PATH>/PLUGIN/maddm with the content of the branch you just downloaded.

We are still working on it (there are still some things we need to implement to that regards), but for the time being you can use that and it should work.

About the Pythia spectra, try to use the patch I suggested which contains also some updates on the spectra handling.
Let me know if the issue persists.

Daniele Massaro

Revision history for this message
Sanket Doshi (sdoshi1) said :
Revision history for this message
Sanket Doshi (sdoshi1) said :

Hi Daniele,

The previous part works fine now but I run into another error:

"Exception : two different matrix-element have the same initial/final state. Leading to an ambiguity. If your events are ALWAYS written in the correct-order (look at the numbering in the Feynman Diagram). Then you can add inside your reweight_card the line 'change keep_ordering True'."

when I run the subsequent commands after launch:

set save_output all
set nevents 100000
set decay 1051 auto
set decay 1061 auto
set decay 1071 auto
set precise
indirect = flux_source
set indirect_flux_source pythia8
set pythia8_card 13:mayDecay True
set pythia8_card 13:onMode 1
set yph1ch1N1 3.512
set yph1ch1N2 0.916
set yph1ch2N1 0.0014
set yph1ch2N2 1.095
set UNe1 1e-4
set UNm1 1e-4
set UNt1 1e-4
set UNe2 4.456e-5
set UNm2 4.456e-5
set UNt2 4.456e-5
set MNe1 1
set MNm1 1
set MNt1 1
set Mchi1 0.6
set Mphi1 1.7
set MNe2 2.61
set MNm2 2.61
set MNt2 2.61
set MChi2 2.14
shower = Pythia8

Would appreciate your help


Revision history for this message
Sanket Doshi (sdoshi1) said :


set reweight_card change keep_ordering True
set reweight_card change use_eventid True

Neither of these commands seem to work, they're not recognized.


Revision history for this message
Daniele Massaro (dmassaro) said :

Hi Sanket,

I'll open a bug report with your error. Could you attach your model to it? So we can test what could be the issue.


Revision history for this message
Sanket Doshi (sdoshi1) said :


Revision history for this message
Sanket Doshi (sdoshi1) said :

Hi Daniele,

Do you have an update?


Can you help with this problem?

Provide an answer of your own, or ask Sanket Doshi for more information if necessary.

To post a message you must log in.