program automatically skips shower and detector setting

Asked by Ruohan Li

Hi everyone,

I'm running MG5_aMC v2.9.9 & MadDM v2.2. The required packages PYTHIA8/PPPC4DMID/Dragon/lhapdf were also installed.
after launch i gave in these commands:

import model DMsimp_s_spin0
define darkmatter xd
generate relic_density
add indirect_detection
output test
launch test
set mxd 1000
press "3" until indirect =flux_earth

then i typed "indirect_flux_earth_method = PPPC4DMID_ep", but it return out "not valid argument"
If i typed "done", then the interface shows setup card with option 1~5, where 2 for choosing the detector simulation program. I cannot change any setup here by typing "2" or by "set=xx..", the program just automatically skip this step and then makes the entire analysis done.

how can i choose indirect_flux_earth_method in this case?

Question information

English Edit question
MadDM Edit question
No assignee Edit question
Solved by:
Daniele Massaro
Last query:
Last reply:
Revision history for this message
Best Daniele Massaro (dmassaro) said :

Hi Ruohan Li,

you are using a wrong syntax.
To set the value of the parameters you need to use:

set indirect_flux_earth_method PPPC4DMID_ep

and not the syntax without `set`, which works in other cases.
Another way to set the parameters is to open the various cards as suggested by the prompt and type the values of the parameters explicitly in the opened file.
In summary, in your run you can set the parameters in the following way (notice the only case in which you don't use the `set` syntax):
launch test
indirect = flux_earth
set mxd 1000
set indirect_flux_earth PPPC4DMID_ep

Regarding your other question: the prompt about the shower program and the detector simulation is not a real prompt: MadDM calls MadGraph internally, passing different options, literally jumping some of the prompts. The only prompt available in MadDM is the one where you select the running modes and you set the parameters.
Hope this answer your question.


Revision history for this message
Ruohan Li (ligraph) said (last edit ):

Thank you Daniele, that solved my question.