zlib installation issue

Asked by krunal on 2017-08-16

Hi,
I am facing an issue with Zlib installation. In the current version of MA5_v1.5, while using its "install zlib" command:

ma5>install zlib
MA5:
MA5: **********************************************************
MA5: Installing zlib
MA5: **********************************************************
MA5: Detecting a previous installation ...
MA5: => not found. OK
MA5: How many cores would you like to use for the compilation ? default = max = 4
   => Answer: 4
MA5: => Number of cores used for the compilation = 4
MA5: **********************************************************
MA5: Creating a devoted folder ...
MA5: Creating a temporary folder ...
MA5: Downloading the package ...
MA5: - 1/1 http://zlib.net/zlib-1.2.8.tar.gz ...
MA5-WARNING: Impossible to access the url: http://zlib.net/zlib-1.2.8.tar.gz
MA5-WARNING: New attempt to access the url: http://zlib.net/zlib-1.2.8.tar.gz
MA5-WARNING: Impossible to access the url: http://zlib.net/zlib-1.2.8.tar.gz
MA5-WARNING: New attempt to access the url: http://zlib.net/zlib-1.2.8.tar.gz
MA5-WARNING: Impossible to access the url: http://zlib.net/zlib-1.2.8.tar.gz
MA5-WARNING: Impossible to download the package from http://zlib.net/zlib-1.2.8.tar.gz to /tmp/krunal/MA5_downloads/zlib.tar.gz
MA5-WARNING: Error(s) occured during the installation.
MA5: Installation NOT complete.
MA5: => Status: [FAILURE]
MA5: **********************************************************
MA5:

So I am facing an issue with the installtion of Zlib.

Question information

Language:
English Edit question
Status:
Solved
For:
MadAnalysis 5 Edit question
Assignee:
No assignee Edit question
Solved by:
Benjamin Fuks
Solved:
2017-08-17
Last query:
2017-08-17
Last reply:
2017-08-16
Best Benjamin Fuks (fuks) said : #1

Hi,

This is fixed in v1.6beta that will soon become the official version. Please use this latter version, and things should be fixed. Otherwise, you can still change the link manually in madanalysis/install/install_zlib.py.

Cheers,

Benjamin

> On 16 Aug 2017, at 19:23 , krunal <email address hidden> wrote:
>
> New question #656306 on MadAnalysis 5:
> https://answers.launchpad.net/madanalysis5/+question/656306
>
> Hi,
> I am facing an issue with Zlib installation. In the current version of MA5_v1.5, while using its "install zlib" command:
>
> ma5>install zlib
> MA5:
> MA5: **********************************************************
> MA5: Installing zlib
> MA5: **********************************************************
> MA5: Detecting a previous installation ...
> MA5: => not found. OK
> MA5: How many cores would you like to use for the compilation ? default = max = 4
> => Answer: 4
> MA5: => Number of cores used for the compilation = 4
> MA5: **********************************************************
> MA5: Creating a devoted folder ...
> MA5: Creating a temporary folder ...
> MA5: Downloading the package ...
> MA5: - 1/1 http://zlib.net/zlib-1.2.8.tar.gz ...
> MA5-WARNING: Impossible to access the url: http://zlib.net/zlib-1.2.8.tar.gz
> MA5-WARNING: New attempt to access the url: http://zlib.net/zlib-1.2.8.tar.gz
> MA5-WARNING: Impossible to access the url: http://zlib.net/zlib-1.2.8.tar.gz
> MA5-WARNING: New attempt to access the url: http://zlib.net/zlib-1.2.8.tar.gz
> MA5-WARNING: Impossible to access the url: http://zlib.net/zlib-1.2.8.tar.gz
> MA5-WARNING: Impossible to download the package from http://zlib.net/zlib-1.2.8.tar.gz to /tmp/krunal/MA5_downloads/zlib.tar.gz
> MA5-WARNING: Error(s) occured during the installation.
> MA5: Installation NOT complete.
> MA5: => Status: [FAILURE]
> MA5: **********************************************************
> MA5:
>
>
> Now, the case is if I download the current version of zlib (1.2.11), then it does not get recongnized by MA5. So I am facing an issue with the installtion of Zlib.
>
>
> --
> You received this question notification because you are an answer
> contact for MadAnalysis 5.

krunal (krunal94) said : #2

Thanks Benjamin Fuks, that solved my question.

krunal (krunal94) said : #3

Hi,

In case someone needs it. Here is the link which works well: http: //zlib.net/fossils/zlib-1.2.11.tar.gz

Cheers,
Krunal