missing profile maas-precise-x86_64-commissioning

Asked by Kodamati Pradeep Vinesh Reddy on 2012-07-03

When I try to accept and commission a node from the MAAS server webpage, I get an error saying

"Missing system profile: invalid profile name: maas-precise-x86_64-commissioning"

I have even run the maas-import-isos" several times and it exits completing all the tasks. But Still I am getting this missing profile error. Can some body help me out with this.

Thanks,
Pradeep Reddy

Question information

Language:
English Edit question
Status:
Solved
For:
MAAS Edit question
Assignee:
No assignee Edit question
Solved by:
Kodamati Pradeep Vinesh Reddy
Solved:
2012-07-10
Last query:
2012-07-10
Last reply:
2012-07-06
Raphaël Badin (rvb) said : #1

First, please make sure that the profile is actually missing:
$ sudo cobbler list profiles
The output should look like this: http://paste.ubuntu.com/1074574/

If the profile 'maas-precise-x86_64-commissioning' is actually missing from the list, then run:
$ sudo maas-import-isos -u
In order to update the profiles and recreate the 'commissioning' profile.

Finally, make sure that the profile was successfully created:
$ sudo cobbler list profiles | grep maas-precise-x86_64-commissioning

Even after running "sudo maas-import-isos -u" still the profiles are missing

pradeep@ubuntu-maas:~$ sudo cobbler list profiles
distros:
   precise-i386
   precise-x86_64

profiles:
   maas-enlist
   maas-precise-i386
   maas-precise-x86_64
   precise-i386
   precise-i386-auto
   precise-x86_64
   precise-x86_64-auto

systems:
   default
   node-54ce52ca-6c07-11e1-96d7-9c8e994c351c

repos:
   precise-i386
   precise-i386-security
   precise-x86_64
   precise-x86_64-security

images:

mgmtclasses:

packages:

files:
pradeep@ubuntu-maas:~$

Can you please suggest me if there is anything else that I have to do?

On further investigating on the same I have found that maas-import-isos fails with the below reason

"failed to get https://maas.ubuntu.com/images/query/precise/ephemeral/released-dl.current.txt
remote query of https://maas.ubuntu.com/images failed"

So I suspect that due to the failure of the maas-ephemeral* distros the commissioning profiles are not getting created. Can you just let me know if that is right?

Gavin Panella (allenap) said : #4

I can access that file, and so can a colleague. I wonder if you're
being an HTTP proxy server that is falling over with that file. From
the same machine as you've been running maas-import-isos, please try:

  curl https://maas.ubuntu.com/images/query/precise/ephemeral/released-dl.current.txt

You should see something like:

precise ephemeral       release 20120424        amd64   ephemeral/releases/precise/release-20120424/precise-ephemeral-maas-amd64.tar.gz maas-precise-12.04-amd64-ephemeral-20120424
precise ephemeral       release 20120424        i386    ephemeral/releases/precise/release-20120424/precise-ephemeral-maas-i386.tar.gz  maas-precise-12.04-i386-ephemeral-20120424

Below is the mentioned error I am getting trying the curl download you mentioned

pradeep@ubuntu-maas:~$ curl https://maas.ubuntu.com/images/query/precise/ephemeral/released-dl.current.txt
curl: (60) SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle"
 of Certificate Authority (CA) public keys (CA certs). If the default
 bundle file isn't adequate, you can specify an alternate file
 using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
 the bundle, the certificate verification probably failed due to a
 problem with the certificate (it might be expired, or the name might
 not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
 the -k (or --insecure) option.

I am able to see the output you have mentioned if I use the "-k" option.

Also I am using a HTTP proxy server for the downloads.

Please let me know how to overcome

I am still waiting for input from you people.. Can you please suggest me a workaround for the above mentioned issue?

Actually the hardware clock in the server was set to a wrong time i.e it was showing as March 10th 2012 which was the reason for the problem.
Once I corrected the time, the profiles and the images got downloaded and the profiles missing error is gone now.

Thanks for your help.!!!

Guanglin Du (dugl) said : #8

Set an environmental variable https_proxy if you're behind a proxy server.

I encountered the same problem as indicated by the title. My office network is behind a proxy server. After searching on the web and a lot of testing, I found that maas-import-isos must use the environmental variable https_proxy=https_proxy://your_proxy_ip_or_domain_name:port_number to fetch files via the proxy server. By the way, I cannot use sudo maas-import-isos directly. Instead, I have to run it this way: (1) first, sudo su - (2) then, maas-import-isos (with or without -u).