error in defining a Juju environment

Asked by shahzeb khan on 2012-04-12

iam defining a Juju environment on ubuntu 12.04LTS but when i give command "juju bootstrap", it generates error i.e

Unexpected Error interacting with provider: 409 CONFLICT
2012-04-13 02:25:01,025 ERROR Unexpected Error interacting with provider: 409 CONFLICT

My environments.yaml file is like:

environments:
  maas:
    type: maas
    maas-server: 'http://127.0.0.1:80/MAAS'
    maas-oauth: 'YQB6PzembfZtLzgy9q:9tzQyQpCbAG38Vf5Ph:EuNhAmH4LXrLJ6wtBUrYqe9wrwCyJrHf'
    admin-secret: 'nothing'
    default-series: precise

Please Help me asap to solve this problem....
Am struck from 2 days in this

Question information

Language:
English Edit question
Status:
Solved
For:
MAAS Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-13
Last reply:
2012-04-27

CONFLICT from maas means that it doesn't have any nodes available for juju to acquire (juju bootstrap needs to boot a node). It's not the best error unfortunately, juju needs fixing to show all the text.

shahzeb khan (08bitshahzebk) said : #2

do we need ubuntu 12.04 server edition or desktop edition on node ???

You need the server edition.

shahzeb khan (08bitshahzebk) said : #4

Sir my every thing worked fine , but when i enter juju status command then an error says
2012-04-13 23:28:27,095 ERROR Invalid host for SSH forwarding: ssh: Could not resolve hostname node-363886f3e436.local: Name or service not known

BUT my dashboard shows one node in MAAS....
i have followed same procedure on https://wiki.ubuntu.com/ServerTeam/MAAS/AddNodes...
But in the last step i have no buuton of Accept & Commission, instead i have start node and pressing start takes me to nothing

Thanks in advance

"node-363886f3e436.local: Name or service not known" means that the master juju node is not up and running or has not installed properly yet as using .local addresses depends on avahi running on the node.

It also sounds like your maas code is out of date, it's *very* fast moving at the moment as we iron out lots of bugs.

Thanks for your time testing with it!

Not heard from the question asker so marking as solved for now.

John Barbee (jbarbee00) said : #7

Julian

I am having the same problem as Shahzeb. I am building my first MAAS in a test environment and ultimately hope to deploy openstack on it. Here is my error when I try to bootstrap my node(s).

2012-05-03 15:10:21,250 INFO Bootstrapping environment 'maas' (origin: distro type: maas)...
Unexpected Error interacting with provider: 409 CONFLICT
2012-05-03 15:10:21,807 ERROR Unexpected Error interacting with provider: 409 CONFLICT

I have set my node to wake-on-lan from the MAAS web interface. I have also manually turned the node back on. Looking at it from the console, it has booted ubuntu 12.04 and is at a login in prompt.

Any help on the 409 CONFLICT error is greatly appreciated.

Hello John

(it's best to open a new question in case your situation is different)

As above in response #1, CONFLICT is what the MAAS server sends to Juju when it cannot allocate any nodes (Juju has an open bug about actually displaying the error text sent to it here).

This means that MAAS thinks all of the nodes are allocated already, or not in a state that can be allocated.

The easiest way out of this is to power off your node, run "juju destroy-environment" and then"juju bootstrap" again.

Andres Rodriguez (andreserl) said : #9

 maas-server: 'http://127.0.0.1:80/MAAS' --> the IP there should be the IP of the MAAS server in the local network, not the loopback :).