Cannot find m210d in the aplications list

Asked by Giannis Avramopoulos

I had some problems installing m210d in openSUSE, so I installed Lucid Lynx 10.04.
I also installed from the Codegrove's PPA:


I have rebooted, but I cannot find nothing like "m210d" in my applications list.

When I give: ~$ status m210d
the return is: m210d start/running, process 842

When I give: ~$ cat /etc/init/m210d.conf
the return is: start on (local-filesystems
                                     and started dbus)

                       stop on runlevel [06]

                       expect daemon

                       exec m210d

Any help? Is it possible that my pen "looks like" but actually isn't Pegasus m210! How can I check what my machine recognizes of my digital pen?

Question information

English Edit question
m210 Edit question
a Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
a (tuomasjjrasanen) said :

So m210d is running. It is the workhorse process running on the background. The user interface is launched by running command: m210c-qt

Unfortunately, there isn't any launcher for it in menus by default. This will be fixed in the next release.

So, you have to either run it (m210c-qt) from the command line or create a launcher for it for example into the desktop by clicking right-mouse button on the desktop -> Create launcher...

If you think your pen is not recognized properly, please run: lsusb when your device is plugged in. M210 device should print "ID 0e20:0101".

Revision history for this message
Best a (tuomasjjrasanen) said :

tuos suggests this article as an answer to your question:
FAQ #1380: “How to start the M210 program?”.

Revision history for this message
Giannis Avramopoulos (johnavramo) said :

Thanks tuos, that solved my question.

Revision history for this message
Andres Muniz (andresmp) said :

Hello, I have a EN202 pegasus pen or scrybe. How do I install this m210 program that seems to make it work? for the moment is seems to do nothing. I looked up in synaptic with no joy.

Revision history for this message
Andres Muniz (andresmp) said :

Sorry for the previous question: found answer in

but got stuck again.

~$ m210c info
ERROR:dbus.proxies:Introspect error on :1.10:/org/codegrove/m210/daemon: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 1 matched rules; type="method_call", sender=":1.56" (uid=1000 pid=6583 comm="/usr/bin/python2.6) interface="org.freedesktop.DBus.Introspectable" member="Introspect" error name="(unset)" requested_reply=0 destination=":1.10" (uid=0 pid=1031 comm="/usr/bin/python2.6))
- /sys/devices/pci0000:00/0000:00:1d.1/usb3/3-1

Bus 003 Device 002: ID 0e20:0101

When running the gui I see the device but the thin is not checked.