Grayed letters in display

Asked by Terence Sambo on 2010-08-28

Hi Chris,

Many, many thanks for the great work you've done and for making it available to all.

Yesterday I made a presentation for the church service this morning. I manually added a few songs and selected a fitting background. In the preview some of the letters did not show, and the letters that did show would show consistently. So for instance:
    Come Thou fount of every blessing
Would show as:
      o e o o nt o e e less g
The words would display OK on the lyricue-server display on the laptop. But just to be sure I tried on my 22" flat-screen and that showed OK too. So I thought it was just a glitch with the preview screens.

This morning to my dismay I found that all the letters that did not show on the preview would show grayed on the beamer / second monitor and all those that did show would show with their normal color on the beamer / second monitor. The same letters would be grayed across all the songs and announcements in the playlist.

I was using Lyricue version 2.3.1 but I tried the cvs2010080901 version and it has the same behavior (I haven't been able to get Lyricue 3 to run properly as to test if this had the same behavior). Any clues?

Question information

Language:
English Edit question
Status:
Solved
For:
lyricue Edit question
Assignee:
No assignee Edit question
Solved by:
Terence Sambo
Solved:
2010-08-28
Last query:
2010-08-28
Last reply:
Terence Sambo (arubislander) said : #1

Saw that bug #584757 deals with this very issue. I linked it.

ChrisDebenham (chris-debenham) said : #2

This is a problem with mipmapped text in libclutter - this is used to scale the text to the screen.
It can be avoided/fixed by running "export CLUTTER_DISABLE_MIPMAPPED_TEXT=1" before loading lyricue (this will fix for preview/miniview)
Setting that environment variable will also fix it for lyricue_display - or you can set the server size in lyricue preferences to exactly match the projector screen size (so clutter won't need to scale the text and so avoiding usage of mipmaps)