following LVPM-transfer I get a "Grub Error 17: Cannot Mount Selected Partition"

Asked by Norwood

I used wubi-7.04 to install Ubuntu 7.04 on a windows partition that I had. After all was up and running I installed LVPM and invoked it using the 'transfer' option. I selected to transfer to the disk partition (/dev/sdc2) that I had put aside for Ubuntu -- partition /dev/sdc1 is where my "windows" installation resides. LVPM transfered all files successfully and grub was installed. When I rebooted I was prompted with the grub menu and I selected the entry for the ubuntu but I get the above error i.e.
                 Error 17: Cannot Mount Selected Partition
When I look at the line that corresponds to the Ubuntu entry I get the following

title Ubuntu, kernel 2.6.20-15-generic
root (hd2,1)
kernel /boot/vmlinuz-2.6.20-15-generic root=UUID=e90db etc etc
intird /boot/initrd.img-2.6.20-15-generic

whereas the entry for the Windows partition reads

root (hd2, 0)
make active
chainloader +1

Since the two operating systems (Windows and Ubuntu) are on /dev/sdc and since I told LVPM to transfer to /dev/sdc2 it makes sense for Ubuntu to be under
(hd2, 1)
but when I select it I get the above error.

If I select the Windows option, I get a menu that lists "Windows" and "Ubuntu" which is the menu that Wubi gave me in the first place.

I think that I followed correctly the instructions for 'transfering' through LVPM. Nonetheless I am getting the above error. Can you help me figure out how to fix it? Thank you in advance!!


Question information

English Edit question
lvpm Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Norwood (norwoodgardens) said :

After a lot of trial and error I discovered the solution to the above problem. Even though fdisk will list the drive where the Windows and Ubuntu OS reside as /dev/sdc which would mean that the corresponding partitions should be referred to as "hd2" in grub, the setting that will make grub boot the Ubuntu installation that resulted from the LVPM-transfer operation is hd0 (!). I do not quite understand why this is the case but I am happy that I can dual boot to Windows/Ubuntu without a problem.

Thank you Geza for a great program that made my transition to Ubuntu feasible!!


Revision history for this message
priyesh07 (goyal-priyesh) said :

hey m getting the same error.
n m a newbie to linux..

can u discuss in detail how to fix the problem..


Revision history for this message
John-Daniel Beaunaux (jdbeaunaux) said :

I second that - would it be possible to have a more detailed explanation of how to fix this error? Thanks!

Revision history for this message
Spiritualblues (bansode) said :

Me too please someone