How to support mpd and xmms2

Created by frank on on 2010-01-24
Keywords:
mpd xmms2
Last updated by:
frank on on 2010-01-24

After 1.3.3, may be 1.3.4 or 1.4.0, lrcShow-X would support mpd and xmms2. Current SVN version support both of them already.

For mpd, you should install mpDris first, then modify "host" and "port" in mpDris.conf, default is "localhost", "6600".

For xmms2, please download "xmms2-mpris-bridge.py" script first, and place it in xmms2' startup.d directory, so that the xmms2 would providing dbus interface automatically. You could get the script here: http://www.sanfanling.cn/attachment.php?fid=92

Now, lrcShow-X is mpd and xmms2's front-end!