can't fetch my package from PPA using apt-get

Asked by Andrew Kay on 2009-03-17

I have a package on my ppa. I put these lines at the end of my /etc/apt/sources.list:

    deb http://ppa.launchpad.net/music1/ppa/ubuntu intrepid main
    deb-src http://ppa.launchpad.net/music1/ppa/ubuntu intrepid main

I downloaded the signing key (of course it happens to be my own) and added it to the list in the authentication box. It looks like it's happy there (how can one tell?)

$ sudo apt-get install longloops
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package longloops is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package longloops has no installation candidate

which looks odd. In synaptic, typing "longloops" in the search box shows nothing.

I can download the longloops_0.1-0ubuntu1_i386.deb file directly from the PPA pool and install it with dpkg without any trouble.

I'm a linux/deb/apt/packaging newbie, so I've probably done something very stupid. Help?

thanks
Andrew

(sorry, I've no idea which Launchpad project this should go to, and worse, no idea how to find out. This is my best guess.)

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad Developer Utilities Edit question
Assignee:
No assignee Edit question
Solved by:
Oleg Koptev
Solved:
2009-03-17
Last query:
2009-03-17
Last reply:
2009-03-17
Andrew Kay (music1) said : #1

should have said: running intrepid, gnome 2.24.1

Best Oleg Koptev (koptev-oleg) said : #2

stupid question - but do you update database after adding sources in source.list? :)

Andrew Kay (music1) said : #3

actually quite a sensible question, the stupidity is all my own.

-- problem seems to be solved after typing apt-get update
-- thank you!

(I still don't know why the Refresh button in Synaptic didn't do this, though. Still can't see this
package there even though I've installed it.)

Andrew

Andrew Kay (music1) said : #4

Thanks Koptev Oleg, that solved my question.

Oleg Koptev (koptev-oleg) said : #5

You're welcome!