Changed something now it's broken

Asked by Rogan

I originally had my destination save point on a drive that had to be mounted to work. This is no longer the case, so LottaNZB won't open and I can't change the destination point because I get this message : Exiting: Fatal Error unable to create directory for option : HellaNZB.DEST_DIR
dirname : /media/DATA error:[Errno 13]
Permission denied: '/media/DATA'

I understand why permission is denied - this location no longer exists - but how do I change it to point somewhere else if it won't open the program to let me change the preferences?

Thanks in advance!

Question information

Language:
English Edit question
Status:
Solved
For:
LottaNZB Edit question
Assignee:
No assignee Edit question
Solved by:
Severin Heiniger
Solved:
Last query:
Last reply:
Revision history for this message
Sander Tuit (avirulence) said :
#1

Hi,

You can edit the file ~/.config/lottanzb/hellanzb.conf and change the
value there into a new directory.

Sander

On Wed, Jan 27, 2010 at 12:26, Rogan
<email address hidden> wrote:
> New question #98842 on LottaNZB:
> https://answers.launchpad.net/lottanzb/+question/98842
>
> I originally had my destination save point on a drive that had to be mounted to work. This is no longer the case, so LottaNZB won't open and I can't change the destination point because I get this message : Exiting: Fatal Error unable to create directory for option : HellaNZB.DEST_DIR
> dirname : /media/DATA error:[Errno 13]
> Permission denied: '/media/DATA'
>
> I understand why permission is denied - this location no longer exists - but how do I change it to point somewhere else if it won't open the program to let me change the preferences?
>
> Thanks in advance!
>
> --
> You received this question notification because you are an answer
> contact for LottaNZB.
>

Revision history for this message
Rogan (saintswithwine) said :
#2

I'm fairly new to linux, how do I find that file to edit it?

Revision history for this message
Sander Tuit (avirulence) said :
#3

In a terminal, you can type: gedit ~/.config/lottanzb/hellanzb.conf

Then search for wrong values (for instance this HellaNZB.DEST_DIR) and
edit them. After this, you can just safe the file and start LottaNZB.

Sander

On Wed, Jan 27, 2010 at 12:49, Rogan
<email address hidden> wrote:
> Question #98842 on LottaNZB changed:
> https://answers.launchpad.net/lottanzb/+question/98842
>
>    Status: Answered => Open
>
> Rogan is still having a problem:
> I'm fairly new to linux, how do I find that file to edit it?
>
> --
> You received this question notification because you are an answer
> contact for LottaNZB.
>

Revision history for this message
Severin Heiniger (severinh) said :
#4

Theoretically, we could change LottaNZB so that it falls back to the default download directory if HellaNZB.DEST_DIR doesn't exist. Would be a nice feature for LottaNZB 0.5.3, wouldn't it?

Revision history for this message
Rogan (saintswithwine) said :
#5

Thanks for your help so far. When I put that into terminal, I get a blank file? I'm confused

Revision history for this message
Best Severin Heiniger (severinh) said :
#6

Well, of course you can also do it without using the terminal.

1. Open your home directory.
2. Make the hidden files and folder visible by pressing Ctrl-H.
3. Open the ".config" directory and the "lottanzb" directory inside of it.
4. The "lottanzb" should contain a file called "hellanzb.conf" open it and change it as described above by Sander.

If you happen to use a very old version of LottaNZB, the "hellanzb.conf" file will be in ".lottanzb" instead of ".config/lottanzb".

Revision history for this message
Severin Heiniger (severinh) said :
#7

The upcoming LottaNZB 0.5.3 will work around this problem so that people won't be forced to manually edit the HellaNZB configuration file anymore if the download directory isn't available.

Revision history for this message
Rogan (saintswithwine) said :
#8

Thank you very much. It turns out that I must have been using an old version - it was in .lottanzb

Changed it and it works now.

Cheers!!