Problem installing lottanzb.

Asked by xenth

Hi, I'm pretty new to linux so if you can, please explain as simple as possible :)
I'm using Opensuse 11.2 x64.

Installed all dependencies, built it, and then when I run it I get this output:

[code]
lottanzb
Traceback (most recent call last):
  File "/usr/local/bin/lottanzb", line 3, in <module>
    from lottanzb.core import App
  File "/usr/local/bin/lottanzb.py", line 3, in <module>
    from lottanzb.core import App
ImportError: No module named core
[/code]

Any idea what I'm doing wrong here?

Thanks in advance!.

Question information

Language:
English Edit question
Status:
Solved
For:
LottaNZB Edit question
Assignee:
No assignee Edit question
Solved by:
Severin Heiniger
Solved:
Last query:
Last reply:
Revision history for this message
Best Severin Heiniger (severinh) said :
#1

Hi xenth,

something must have gone wrong during the installation, because the file /usr/local/bin/lottanzb.py causes the problem. That file shouldn't exist. You can delete it using

sudo rm /usr/local/bin/lottanzb.py

Most probably, LottaNZB should work after you've done that. I'll check what can be done to prevent this from happening to other users.

Revision history for this message
xenth (a2594149) said :
#2

Hey, thanks for the quick response :-)

Deleting the file, and also renaming the "lottanzb.pyc" file did the trick, thanks a lot! :)

Revision history for this message
xenth (a2594149) said :
#3

Thanks Severin Heiniger, that solved my question.

Revision history for this message
xenth (a2594149) said :
#4

I am trying to read the help contents to read the manual, but it's returning an error :-(

Unable to load page
The requested URl "ghelp:lottanzb" is invalid