LottaNZB fatal error'>: Cannot Continue HellaNZB needs write accsess to directories

Asked by BinoPanda on 2009-06-10

Hello, I am running Ubuntu 9.04 64bit
 I tired installing HellaNZB from source, it didn't work out so deleted what traces of it I could find and installed HellaNZB from synaptic.

 Next I installed LottaNZB. when I started lottanzb for the first time it gave the error "Unable to create directory for option: Hellanzb.DEST_DIR (Error 13, Permission denied)"

I tried to get around this by running LottaNZB as root. This allowed the program to start but it would not download.

 I quit the program and when I went back in and tried to set up LottaNZB for stand-alone mode I got the error "fatal error'>: Cannot Continue HellaNZB needs write accsess to directories" I have looked for solutions to both of these error messages and deleting the .lottanzb directory does not work and I am unable to find and delete the Hellanzb file left from installing the program from source, this file is supposedly located on one of my python folders.

thank you!

Question information

Language:
English Edit question
Status:
Solved
For:
LottaNZB Edit question
Assignee:
No assignee Edit question
Solved by:
Severin Heiniger
Solved:
2009-06-12
Last query:
2009-06-12
Last reply:
2009-06-10
Best Severin Heiniger (severinh) said : #1

Hi BinoPanda,

when launching LottaNZB the first time, it will try to import existing HellaNZB configuration files. It looks as if LottaNZB imported a configuration file from somewhere where the DEST_DIR option (the location of the download directory) was set to something you don't have write access to: may be /etc or something like that. HellaNZB ships with a very weird default configuration file, but unless you renamed it from /etc/local/hellanzb.conf.sample to /etc/hellanzb.conf it won't have been imported.

You sould have a look at the hellanzb.conf file in .lottanzb first and check what DEST_DIR is actually set to by opening it.

Next, please remove .lottanzb and .hellanzb again. If you cannot delete it from the file manager use the command line like "sudo rm -R ~/.lottanzb" and "sudo rm -R ~/.hellanzb". Next check if there is any HellaNZB configuration file in /etc. You can delete it using "sudo rm /etc/hellanzb.conf".

It's also a good idea to start LottaNZB from command line using "lottanzb --debug" so that we can see if a configuration file is imported and where it's from (of course this only appears once: when launching LottaNZB after having deleted .lottanzb).

Let's hope it works!

BinoPanda (zlachman) said : #2

hello, thank you for the speedy advice! The program now starts and I added my news server: reader.ipv6.xsnews.nl and my username and password for the site but I am unable to download anything with LottaNZB.

I tried using the Pan newsreader with the same settings and it did download the content from the NZB files.

If you have any suggestions on why this is happening or how to fix it, I would greatly appreciate it.

Thanks again!

BinoPanda (zlachman) said : #3

started working

BinoPanda (zlachman) said : #4

Thanks Severin Heiniger, that solved my question.