Firefox can't launch LottaNZB when clicking NZB

Asked by Mikal Krogstad on 2009-01-23

Whenever clicking a NZB, Firefox gives me the option to Open or Save the file. The preselected entry to open is "LottaNZB - Automated Usenet Client", but when clicking OK, I get "/tmp/blah blah.nzb could not be opened, because the associated helper application does not exist. Change the association in your preferences".

I checked the Firefox helper program preferences, but the NZB file type is not listed. If I _save_ the file and launch it from the desktop, LottaNZB opens just fine. Finding and editing other file types -- as PDF, WMV, etc -- in the Firefox preferences works just fine.

This is a fully updated Ubuntu AMD64 2008.10, using Firefox 3.0.5. Any help would be appreciated.

Question information

nhasian (nhasian) said : #1

Hello in firefox's Edit->Preferences->Applications you should have:

NZB file (application/force-download) Use lottanzb
NZB file (application/x-nzb) Use lottanzb

Thank you for your reply. By "Firefox helper program preferences", I meant Edit->Preferences->Applications. NZB is not listed as a filetype there, that is the weird thing. Since Firefox offers to open it with LottaNZB when I click a NZB, it must recognize NZB files on _some_ level.

Severin Heiniger (severinh) said : #3

Hi Mikal Krogstad,

you're not the only one with this problem and right now, I'm asking myself why I haven't looked into it yet. :-/ I'll try to find a solution after dinner.

Thanks for reporting/confirming this issue.

Severin Heiniger (severinh) said : #4

This is weird. I was just about to track down the NZB file association problem, when I noticed that it worked just fine. I don't have a clue what I did, but you might want to try to reinstall LottaNZB. :-/

I tried with 0.4.1, and noticed these messages from the gdebi output when installing:
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'fonts/package'
Unknown media type in type 'interface/x-winamp-skin'

Can't see it is related, but they are the only error messages I get. Oh, and I tried with Firefox closed, made no difference.

I searched through my .mozilla directory for anything related to MIME types, and found one file.
grep -i 'nzb' ~/.mozilla/firefox/ocjp1vli.default/mimeTypes.rdf returned nothing, while similar searches for PDF and MPEG did. I don't know Firefox well enough to know if there are other places these are defined.

mrsdoyle (mrsdoyle4) said : #6

This is easily fixed. make sure that you can see hidden files and folders in explorer and goto C:\Users\Your username here\AppData\Roaming\Mozilla\Firefox\Profiles\ and open the default folder and you will find mimeTypes.rdf delete it. Done.

Note do not delete mimeTypes.rdf in program folder.

Can you help with this problem?

Provide an answer of your own, or ask Mikal Krogstad for more information if necessary.

To post a message you must log in.