Preferences menu-item is inactive / Connection mode is not saved

Asked by Tim Düllmann on 2008-10-23

I am using LottaNZB 0.3.1, which I compiled myself under a stable Gentoo system.

The menu-item "Preferences" is inactive and greyed out. Maybe the other problem is related:

LottaNZB doesn't save my connection mode. I would like it to remember the remote-connection option. Instead it always complains to not be able to find the local hellanzb and lets me switch to remote-connection manually.

Interestingly the remote details like host and password are saved.

Thank you very much for this great software, though!

Question information

Language:
English Edit question
Status:
Solved
For:
LottaNZB Edit question
Assignee:
No assignee Edit question
Solved by:
Tim Düllmann
Solved:
2008-10-28
Last query:
2008-10-28
Last reply:
2008-10-23
Sander Tuit (avirulence) said : #1

Hi Tim,

The fact that the menu-item "Preferences" is inactive is because we
are not able to change any preferences when one is using a remote
connection. This is because we cannot change the hellanzb.conf file on
the remote computer.

The second problem is more severe. Could you please file a bug report for this?

Thanks,

Sander

On Thu, Oct 23, 2008 at 11:32, Tim Düllmann
<email address hidden> wrote:
> New question #48809 on LottaNZB:
> https://answers.launchpad.net/lottanzb/+question/48809
>
> I am using LottaNZB 0.3.1, which I compiled myself under a stable Gentoo system.
>
> The menu-item "Preferences" is inactive and greyed out. Maybe the other problem is related:
>
> LottaNZB doesn't save my connection mode. I would like it to remember the remote-connection option. Instead it always complains to not be able to find the local hellanzb and lets me switch to remote-connection manually.
>
> Interestingly the remote details like host and password are saved.
>
> Thank you very much for this great software, though!
>
> --
> You received this question notification because you are an answer
> contact for LottaNZB.
>

Severin Heiniger (severinh) said : #2

Hi Tim,

the reason why the preferences menu entry is disabled in your case is because it's only available in standalone mode right now. We might need to rethink this. The preferences dialog has been made modular in the latest (unstable) code of LottaNZB, which might enable us to display preferences depending on the active mode. In your case, there would be no other options than bandwidth throttling and the "Start minimized" option.

As for the more serious issue you're encountering: The fact that the remote connection information are kept when you restart LottaNZB indicates that your LottaNZB configuration file was saved, but either not properly or there is a bug when you start LottaNZB.

I assume you get the "The HellaNZB executable could not be found. [...]" respectively "Die Programmdatei von HellaNZB konnte nicht gefunden werden. [...]" error message. I wonder if there are any helpful messages in the LottaNZB log, which can be found in ~/.lottanzb/log. Additionally, you could post the content of the LottaNZB configuration file in ~/.lottanzb/lottanzb.xml after having quit LottaNZB (removing the IP address won't hurt).

We could turn this question into a bug report.

Tim Düllmann (tim-duellmann) said : #3

Thanks for this quick help! Alright, I understand, that the preferences menu is a little design flaw.
Regarding the other problem, I followed your advice and made a bug report:

https://bugs.launchpad.net/lottanzb/+bug/290449