Error "Could not connect to localhost. This might be due to network issues." in stand alone mode.

Asked by Old Man Jut on 2008-10-15

I just installed lottanzb on a fresh ubuntu 8.04 system. it has always worked flawlessly in the past, but is giving me:

Error Could not connect to localhost. This might be due to network issues.

whenever I launch it. the network connection is working, i'm not behind a firewall, all ports are default, hellanzb.conf is default. I have purged and reinstalled both hellanzb and lottanzb multiple times.
Little help?

Question information

Language:
English Edit question
Status:
Solved
For:
LottaNZB Edit question
Assignee:
No assignee Edit question
Solved by:
Old Man Jut
Solved:
2008-10-15
Last query:
2008-10-15
Last reply:
Old Man Jut (sendtojut) said : #1

Oh, by the way, don't forget to install python-openssl if you're connecting to an SSL news server.
Oop.

Severin Heiniger (severinh) said : #2

Would you mind telling us what the reason for this issue was and how you fixed it? It could help us answer similar questions by other users in the future.

Sander Tuit (avirulence) said : #3

Severin, he gave his answer: "Oh, by the way, don't forget to install
python-openssl if you're connecting to an SSL news server.
Oop."

On Wed, Oct 15, 2008 at 12:52, Severin Heiniger
<email address hidden> wrote:
> Question #48037 on LottaNZB changed:
> https://answers.edge.launchpad.net/lottanzb/+question/48037
>
> Severin Heiniger posted a new comment:
> Would you mind telling us what the reason for this issue was and how you
> fixed it? It could help us answer similar questions by other users in
> the future.
>
> --
> You received this question notification because you are an answer
> contact for LottaNZB.
>

Old Man Jut (sendtojut) said : #4

Sorry for being vague. It was giving me that error because I didn't have python-openssl install and was trying to connect to an SSL news server.
Word, to the wise: be sure you've installed all dependencies first.