Lottanzb will not run, no error messages

Asked by Ma3oxuct on 2008-07-21

Lottanzb I have installed it via both the setup.py script as well as via Gentoo ebuild. When I run Lottanzb the gui does not come up. I get no error messages on the console. No process is spawned either because ps aux does not list lottanzb anywhere. Where should I start with debugging this?

Lottanzb version: 0.3.1
pygtk version: 2.12.0
elementtree version: 1.2.6

Let me know if more info is needed. Thank in advance for any help.

Question information

Language:
English Edit question
Status:
Solved
For:
LottaNZB Edit question
Assignee:
No assignee Edit question
Solved by:
Ma3oxuct
Solved:
2008-07-22
Last query:
2008-07-22
Last reply:
2008-07-21
Ma3oxuct (ma3oxuct) said : #1

I tried running /usr/bin/lottanzb through python shell command-by-command. It turns off as soon as lottanzb is imported, i.e.:

from lottanzb import lottanzb

Exit status code is 0.

Severin Heiniger (severinh) said : #2

Hi Ma3oxuct,

I probably know what the problem is. In LottaNZB 0.3.1, logging to the console is enabled late, too late in your case. Check the log file in ~/.lottanzb. It most certainly contains an error message that was meant to be printed out on the console.

This is an issue that will be fixed in LottaNZB 0.4. Sorry for the inconvenience.

Ma3oxuct (ma3oxuct) said : #3

Yep, I see the error message now, I think I can solve the rest :). Thanks for the quick response!

Sander Tuit (avirulence) said : #4

Hi Ma3oxuct, can you please tell us what the problem was?

Ma3oxuct (ma3oxuct) said : #5

The problem was that lottanzb cannot find pygtk modules. I have pygtk installed. I haven't had time to look in to this.

Severin Heiniger (severinh) said : #6

This error message is show if one of the following statements throws an exception:

    import pygtk
    pygtk.require("2.0")

    import gobject
    import gtk
    import gtk.glade

You might try to run each of them in a Python console.