Duplicate downloads in Download folder

Asked by Eric Fleming on 2008-07-10

I recently re-installed Ubuntu Hardy Heron, and as such re-installed LottaNZB (version 0.3.1), but I'm getting some strange behavior.

When a download completes, and all processing is finished, I'm getting the download in my download folder as I expect, but I'm also getting a duplicate of that download, with "hellanzb_renamed0" attached at the end. The two folders are identical in every way.

In addition, I noticed that my Home folder seemed to be getting a bit full, and when I investigated, found that my temporary files aren't being deleted after a download is complete. Most are, but the daemon.processing folder (inside the nzb folder inside the hidden hellanzb folder, isn't getting deleted, so basically everything I download ends up in triplicate... the one I want in my Downloads folder, the duplicate that hellanzb creates, and the one that hellanzb doesn't delete.

I checked the log file and nothing jumped out at me as being a problem, likewise I took a look at the hellanzb config file (inside the hidden lottanzb folder in my home folder), but didn't see anything there that I thought would change this behavior. Anything people can offer to solve this would be marvelous, and let me know if you need any more info from me.

Question information

Language:
English Edit question
Status:
Solved
For:
LottaNZB Edit question
Assignee:
No assignee Edit question
Last query:
2008-07-21
Last reply:
2008-07-21
Severin Heiniger (severinh) said : #1

Hi Eric,

sorry for not getting back to you earlier. In fact, not knowing what to write kept me from answering. Additionally, it's kind of unusual that users check the log and configuration files before asking questions here. ;-)

The obvious thing is that this problem is a HellaNZB related one. Since we're not the developers of HellaNZB, we don't know much about the internals of HellaNZB (yet). The suffix "_hellanzb_renamed" is added to downloaded items if there's already a download with exactly the same name.

To be honest, I've got no clue what causes this issue and I've never experienced or heard about something similar. The "brute-force" way of solving problems with HellaNZB/LottaNZB - deleting both .lottanzb and .hellanzb - isn't that promising, as you encountered this problem since you installed LottaNZB in a fresh Hardy Heron system.

Setting Hellanzb.DELETE_PROCESSED to True won't help either I guess, as this is already the default setting and is acutually not connected to the daemon.processing directory.

If you can't figure out how to iron out your problems, the only thing I can do for you at this point of time is to point you out to the #hellanzb channel on freenode.net. There are 20 users online right now. Let's hope one of them is more experienced than me.

-- Lantash

Severin Heiniger (severinh) said : #2

Just an idea, I don't know if it helps:

try to enable the logging of debug messages by uncommenting the DEBUG_MODE option in your ~/.lottanzb/hellanzb.conf file (LottaNZB needs to be shut down first) and setting its value to something like this:

Hellanzb.DEBUG_MODE = "/home/you/Desktop/helladebug"

If this doesn't help you solve the problem yourself, it will at least be what's the HellaNZB channel members are going to ask for.

Severin Heiniger (severinh) said : #3

You're problem might be related to bug #208409. See https://bugs.launchpad.net/lottanzb/+bug/208409. This bug has been open for quite a while and I don't know if St├ęphane has found a solution to the problem.

Severin Heiniger (severinh) said : #4

We seem to have triaged bug #208409. If your download directory is located on a FAT or NTFS partition try to use one on a ext3 partition or similar. Wonder if it fixes your problem.

Eric Fleming (ericcflem) said : #5

Yes! That worked... thanks a ton!
Eric

On Mon, Jul 21, 2008 at 5:13 AM, Severin Heiniger <
<email address hidden>> wrote:

> Your question #38788 on LottaNZB changed:
> https://answers.edge.launchpad.net/lottanzb/+question/38788
>
> Severin Heiniger requested for more information:
> We seem to have triaged bug #208409. If your download directory is
> located on a FAT or NTFS partition try to use one on a ext3 partition or
> similar. Wonder if it fixes your problem.
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.edge.launchpad.net/lottanzb/+question/38788
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Severin Heiniger (severinh) said : #6

Marking the question as solved.