Error: Traceback (most recent call last):

Asked by erik070 on 2008-07-02

I trying to setup LottaNZB.

Got LottaNZB installed trough a .deb package. When I first started LottaNZB I got a usage mode selection, here i chose "Stand-alone". I have HellaNZB installed, but being a linux/Ubuntu noob I realized that Hellanzb without a GUI would not be for me. So I chose LottaNZB with the "stand-alone" mode.

I've filled in the server information (adress, port, username & password), left the "HellaNZB information" as it was. When I push "apply" I get an error:

Error:
Traceback (most recent call last):

I don't know what it means, but I think it has something to do with HellaNZB. When I change the "HellaNZB information" the error changes to (deleted the B from "HellaNZB"):

Error:
/bin/sh: /usr/bin/hellanz: not found

Is this a common problem? I couldn't find other people who had this problem through Google.
And is there a solution?

Question information

Language:
English Edit question
Status:
Solved
For:
LottaNZB Edit question
Assignee:
No assignee Edit question
Solved by:
erik070
Solved:
2008-07-02
Last query:
2008-07-02
Last reply:
2008-07-02
Severin Heiniger (severinh) said : #1

Hi erik070,

it's obvious that "Traceback (most recent call last):" doesn't give us any information about what has actually gone wrong. So that's what I ask you to do: Launch LottaNZB again, don't change the "Executable" field and hit "Apply". Once the "Traceback (most recent call last):" error message appears, go to the hidden directory .lottanzb in your home directory and copy&paste the content of the file "log".

Thanks in advance. Let's hope the bug you encountered isn't a widespread one.

erik070 (erik-troost) said : #2

The contents of my log:

02.07.08 13:42 INFO The LottaNZB configuration file doesn't exist.
02.07.08 13:42 INFO Starting LottaNZB 0.3 using Python 2.5.2.
02.07.08 13:42 DEBUG Starting backend thread...
02.07.08 13:42 INFO The LottaNZB configuration file couldn't be found or might be invalid. Launching usage mode selection window...
02.07.08 13:42 DEBUG Launching GUI...
02.07.08 13:43 DEBUG HellaNZB preferences saved.
02.07.08 13:43 ERROR Could not start the HellaNZB daemon.
02.07.08 13:43 ERROR Could not enter usage mode 'Stand-alone mode'.
02.07.08 13:43 ERROR Traceback (most recent call last):

Seems HellaNZB couldn't be started. Is that a problem with Hella or with Lotta loading Hella?

Severin Heiniger (severinh) said : #3

In normal "cases" LottaNZB prints out the error message put out by HellaNZB if launching it fails. Seems like we're not getting closer to the solution by having a look at .lottanzb/log. Would you mind sending us the content of .hellanzb/log? Should have asked you to post this one in the first place. Sorry.

By the way: What version of Ubuntu are you using?

erik070 (erik-troost) said : #4

I don't have a folder called .hellanzb, so couldn't the log file.

Seriously beginning to doubt that I have Hellanzb installed correctly. Synaptic says I do have it installed(version 0.13), and in the folder /usr/bin/ there is a "hellanzb" & "hellanzb.py" file. Already tried reinstalling Hellanzb through Synaptic with no luck.

BTW. I'm using Ubuntu 8.04

Severin Heiniger (severinh) said : #5

I'm quite sure HellaNZB died in an unhandled exception in an early startup phase. That's why the .hellanzb directory hasn't been created. If there's an error when launching HellaNZB, LottaNZB currently only displays the first output line, which was "Traceback (most recent call last):" in your case.

The file hellanzb.py in your /usr/bin directory indicates that you seem to have HellaNZB installed both using Ubuntu's package management and from the HellaNZB source (a "hellanzb" file is created by the Ubuntu package and a "hellanzb.py" file by HellaNZB's source installation mechanism).

If you've really installed HellaNZB from the source before, there must be a directory Hellanzb in /usr/lib/python2.5/site-packages/. Try to remove it using
sudo rm -R /usr/lib/python2.5/site-packages/Hellanzb

Now, just try to run "hellanzb" on the command line. This will finally show us the actual error message.

erik070 (erik-troost) said : #6

Your right, tried to install it via a source package a while back, didn't know it could matter.

Removing the package with sudo rm -R /usr/lib/python2.5/site-packages/Hellanzb seems to have helped. Lotta is starting up correctly now.

Thanks for the good en quick help.

Severin Heiniger (severinh) said : #7

You're welcome. Have fun with LottaNZB!