Upgraded to 0.6, get 'Http error code 404' in window titled 'Start Downloading'

Asked by theirongiant

Installed 0.6 according to the instructions on the Ubuntu downloads page. Started it up and installed sabnzbd. Restarted and ran Lottanzb Usenet Downloader. On the Start Downloading window the is a Http error code 404 message and i can't do anything else. Any clues, can't see anything obvious.

Question information

Language:
English Edit question
Status:
Solved
For:
LottaNZB Edit question
Assignee:
No assignee Edit question
Solved by:
Severin Heiniger
Solved:
Last query:
Last reply:
Revision history for this message
Severin Heiniger (severinh) said :
#1

Hi theirongiant,

when starting LottaNZB, it first tries to connect to SABnzbd by accessing http://localhost:8080/api in order to detect if SABnzbd is already running. The fact that you're getting a 404 HTTP error indicates that it's indeed getting a response, but the thing that is responding doesn't seem to be SABnzbd (because the error means "not found"). Is it possible that you have any other application or service running on your computer that exposes a web interface on the same port 8080? You might want to open http://localhost in your browser.

Revision history for this message
Severin Heiniger (severinh) said :
#2

What I meant was http://localhost:8080/ of course.

Revision history for this message
theirongiant (markaduncan74) said :
#3

Ah, Oracle Express Edition 10g runs on that port. Not sure which will be easier to move. I'll have a look an see if i can bump Oracle to another port but how difficult would it be to change ports for lotta/sabnzbd

Revision history for this message
Best Severin Heiniger (severinh) said :
#4

You can change the port SABnzbd listens on by editing the property 'port' in ~/.sabnzbd/sabnzbd.ini. LottaNZB doesn't need to be configured, it will figure out the right port on its own.

Have fun with LottaNZB!

Revision history for this message
Severin Heiniger (severinh) said :
#5

By the way, it might be a good idea to make the error message in LottaNZB more specific, i.e. by telling the user that another application is already using that port.

Revision history for this message
theirongiant (markaduncan74) said :
#6

Cool, thanks for the advice. Yeah i think a message saying that another process is already running on that port would be clearer.

Cheers

Mark

Revision history for this message
theirongiant (markaduncan74) said :
#7

Thanks Severin Heiniger, that solved my question.

Revision history for this message
b8e5n (b8e5n) said :
#8

I Have this problem too, so i have to stop apache2 and tomcat to be able to launch lotta.

Revision history for this message
b8e5n (b8e5n) said :
#9

I forgot to say that before, but i changed the port and it works in the same time as apache.

Thanks Severin Heiniger !