How to set Lottanzb and Qnap ?

Asked by artik on 2010-08-27

I have a QNAP with sabnzb installed. The Qnap IP is 192.168.0.1. I set sabmonitor on chrome with these settings :

SABnzbd URL : http://192.168.0.1:8800/sabnzbd/
APIkey : 6f1307b25e4*****************************

And it works. But Lotta ask me a password :S how to configure it to get it working ? what is this password, I tested All, nothing

Thanks in advance !

Question information

Language:
English Edit question
Status:
Solved
For:
LottaNZB Edit question
Assignee:
No assignee Edit question
Solved by:
artik
Solved:
2010-08-28
Last query:
2010-08-28
Last reply:
2010-08-28
Severin Heiniger (severinh) said : #1

Hi artik,

most probably, there's a bug in LottaNZB. The dialog for setting up such a remote access in LottaNZB is known to be rough around the edges. It will definitely need to be fixed prior to the release of LottaNZB 0.6.

You can work around the problem by manually editing LottaNZB's configuration file ~/.config/lottanzb/lottanzb.conf

The content of section [backend.sessions] should be
active = remote

The content of section [backend.sessions.remote] should be
api_key = 6f1307b25e4*****************************
host = 192.168.0.1
https = False
password = ""
port = 8080
username = ""

After saving the configuration file, start LottaNZB.

artik (jeff-artik) said : #2

Hi ! Many thanks for this fast answer. I tried to test differents settings, but it seems your synthax is not correct. For example :

your :

[backend.sessions]
active = remote

you suggested me, is in fact :

[modes]
active = remote_frontend

For the rest :

[modes.remote_frontend]
address = 192.168.0.1
api_key = 6f1307b25e4*****************************
https = False
password = ******
port = 8800
username = artik

I tried many things, but I always get a password error. For the username I tried for exmaple :

"artik"
""
artik

username
user

But it doesn't works. Any idea of the correct synthax ? :)

artik (jeff-artik) said : #3

Oh ! also, it's not :

host = 192.168.0.1

but

adress = 192.168.0.1

Severin Heiniger (severinh) said : #4

You configuration file looks like the one of LottaNZB 0.5. LottaNZB 0.5 is based on HellaNZB and thus cannot be used to manage SABnzbd downloads. When writing the above answer, I assumed that you've been reading [1] and installed the daily builds of LottaNZB 0.6. When LottaNZB 0.6 is launched for the first time, the configuration is upgraded to the new version (even before connecting to SABnzbd).

[1] http://www.lottanzb.org/2010/07/lottanzb-0-6-daily-builds-available/

artik (jeff-artik) said : #5

OOooohhhhhh !!!! Amazing !! it works :)

But .... Why I can't see the tray icon anymore ? (that's the most important feature à was looking for ;) )

Severin Heiniger (severinh) said : #6

It's great to hear that it works for you now. Unfortunately, the application indicator (tray icon) has not been ported to LottaNZB 0.6 yet, because the plug-in infrastructure is still not available. I cannot give any guarantees whether it will be part of LottaNZB 0.6, but, being an important feature, it will certainly be implemented sooner or later.

artik (jeff-artik) said : #7

thanks Severin for these very fast answers. I'm designer, also if you need any free parts of graphics skills, juste ask me. Did you program to make differents isons for tray state ? (that what I was thinking about graphiks), ex : idle, offline, downloading, and number of nzn in queue... that could be so cool feature (dunno if it's still here, 0.5 didn't worked for me).

Last thing : so in my case, there is no way to get lotta tray working ? (so the 0.5 definitly won't work ?)

Very friendly
Jeff

Severin Heiniger (severinh) said : #8

Unfortunately, there's indeed no way to get the application indicator (tray icon) running at this point of time in the development of LottaNZB. As an alternative, you could move the LottaNZB window to the second virtual desktop, so that it doesn't use space in the window list.

It's great to hear from you that you're interested in contributing to the LottaNZB project using your graphics skills! Using different icons for different states of the application may indeed be worth a thought. I also thought about shipping a set of monochrome icons with the LottaNZB package for Ubuntu to make it integrate more naturally with the default theme. But an initial attempt to do so wasn't that successful due to my lack of Inkscape skills.

artik (jeff-artik) said : #9

I'll wait the tray icon. As soon as you get it working, I start working on all icons you want ;) (Need to pend few free time on soft I'll use ;)). If you have any news, just reply in this topic, and I'll back immediatly to work on lotta.

Stay with my sabmonitor on chrome :'(

Severin Heiniger (severinh) said : #10

Good news!

The tray icon has found its way into LottaNZB 0.6, because it would indeed represent a severe regression compared to LottaNZB 0.5! It cannot be enabled or disabled through the UI (but manually using the configuration file) and will be enabled for new users by default. It's part of the latest daily builds of LottaNZB 0.6.

artik (jeff-artik) said : #11

Nice Severin ! I sent you a mail yesterday ;) You received it ?