Can't Start LottaNZB Keep Getting Error About usr/share/kiwi/pixmaps/validation-error-16.png

Asked by MM on 2010-07-21

When I try to start LottaNZB from a terminal this is what I get back:

sar@slackware:~$ lottanzb
Traceback (most recent call last):
  File "/usr/bin/lottanzb", line 3, in <module>
    from lottanzb.core import App
  File "/usr/lib/python2.6/site-packages/lottanzb/", line 72, in <module>
    from lottanzb.util import (
  File "/usr/lib/python2.6/site-packages/lottanzb/", line 41, in <module>
    from lottanzb.external.builderloader import BuilderWidgetTree
  File "/usr/lib/python2.6/site-packages/lottanzb/external/", line 29, in <module>
    from kiwi.ui.widgets import checkbutton, combobox, entry, spinbutton, textview
  File "/usr/lib/python2.6/site-packages/kiwi/ui/widgets/", line 33, in <module>
    from kiwi.ui.proxywidget import ProxyWidgetMixin
  File "/usr/lib/python2.6/site-packages/kiwi/ui/", line 186, in <module>
    environ.find_resource('pixmap', 'validation-error-16.png'))
glib.GError: Couldn't recognize the image file format for file '/usr/share/kiwi/pixmaps/validation-error-16.png'

What's with this ?

glib.GError: Couldn't recognize the image file format for file '/usr/share/kiwi/pixmaps/validation-error-16.png'

I've tried compiling two different versions and I keep getting the same thing.

For python-kiwi >= 1.9.9 I take it this is the right source:


Question information

English Edit question
LottaNZB Edit question
No assignee Edit question
Last query:
Last reply:
MM (mmme) said : #1

Problem solved, the source needs to be fixed, because when building it, it installs some files into /usr/share/mime that over write the originals in the system and mess it up.

These should not be in the source only the applications and packages files need to be there because when the mime database is updated these entries will be placed into these files...


Severin Heiniger (severinh) said : #2

Sorry for not answering your question earlier. I didn't have access to the Internet for a few days.

I suppose that you're talking about Kiwi's source. When installing LottaNZB, lottanzb.xml is installed into /usr/share/mime, which doesn't seem to be a problem.

Kiwi is indeed not a polished piece of software and it's not actively worked upon anymore. LottaNZB 0.6 fortunately won't depend on it and I'm sorry that it caused you troubles getting LottaNZB 0.5.x to work. You can read more about the upcoming LottaNZB 0.6 at


Can you help with this problem?

Provide an answer of your own, or ask MM for more information if necessary.

To post a message you must log in.