Can i restart partly downloaded usenet downloads?

Asked by robinwilli on 2010-03-21

Hi there - i am new to the world of usenet and have a slight problem. I have tried downloading a large file then had to shut down my laptop before it finished downloading. I stopped LottaNZB, then shutdown my machine. When i restarted it, the client recognised i had tried to download a file but it started from the beginning again, not where it had left off.
I was wondering is it possible to stop a usenet download part way through then resume the download from where you left off just like you do with torrents?

Question information

Language:
English Edit question
Status:
Solved
For:
LottaNZB Edit question
Assignee:
No assignee Edit question
Solved by:
robinwilli
Solved:
2010-03-23
Last query:
2010-03-23
Last reply:
2010-03-21
Severin Heiniger (severinh) said : #1

Hi robinwilli,

welcome to the world of Usenet! :-) LottaNZB is perfectly capable of resuming any download from where it had left off. Obviously, you've encountered a bug. Right now, I don't have any helpful explanation for your problem. Can it be reproduced, meaning that it happens with every download? Does it matter whether you shut your computer down or not after quitting LottaNZB?

I'd love to help you track down this issue. It might also help if you tell us what version of LottaNZB and what Linux distribution you're using.

Regards,
Severin

robinwilli (robin-williams) said : #2

Hi Severin - thanks for such a speedy reply. I have only just started using usenet and only discovered this issue yesterday but let me tell you what i have seen so far.
As far as i know, this is reproduceable as once i saw the issue i tried stopping and starting a download a couple of times and got the same result.
If i pause the download i think its ok, but i shall have to experiment with actually stopping the client with the machine runing a bit to give you a more concrete answer on that question.
I do know that if i shut down my machine after pausing a download then restart my machine and lottaNZB, then the client remembers what it was meant to be downloading but it appears to start the download from the very begining again.
I am using Ubuntu Karmic, 9.10 with LottaNZB client version 0.5.3
If you need anymore info then let me know and again, thank you....

robinwilli (robin-williams) said : #3

Hi - i think i may have resolved the issue. I removed the package then reinstalled and now i can restart downloads again :) Not sure what the problem was, maybe the package didn't install correctly 1st time? I'll try to mark this as solved and re open if i get the issue again ....

Severin Heiniger (severinh) said : #4

Hi robinwilli, sorry for not getting back to you earlier. It's great to hear that you seem to have resolved the issue, even though I consider it unlikely that the package not being installed correctly was the cause of it. Unfortunately, I still can't provide you with a better answer and thus hope that you won't encounter the issue again in the future. Of course, always feel free to reopen the question if necessary.