Lottanzb downloads stop working

Asked by lfcobra on 2010-02-28

OS: Ubuntu 9.10
Lottanzb version: 0.4.0 and 0.5.3

So before i get into the problem let me say that while this program worked it was amazing! By far one of the best pieces of open source software I have ever used.

OK now for the problem. I installed Lottanzb (0.4.0) using the ubuntu software center. Installation and setup went fine. Began downloading .nzb files with no problems whatsoever and it worked flawlessly for about a week. Today I had 4 .nzb files queued, the first 2 downloaded as expected but when the 3rd file was suppose to start downloading its status changed from "Queued" to "0%" and stayed there for about 30 minutes at which point I kinda figured something was wrong.

Trying to solve the problem I did the following:
Restarted Lottanzb
Restarted my computer
Uninstalled (apt-get remove --purge) lottanzb and hellanzb
Reinstall (once again using ubuntu software center)
Uninstalled again (this time using find to locate any file that had hellanzb or lottanzb in the file name and deleting them)
Installed NEW 0.5.3 using the ubuntu package found on the download page of the lottanzb website

None of this solved the issue so I then turn to Google. Several sites say that the issue is not lottanzb but hellanzb. They suggest fixing by modifying entries in the hellanzb.conf file (changing Hellanzb.SMART_PAR = False). I did this to both the /ect/hellanzb.conf file and the ~/.lottanzb/hellanzb.conf (<-- i'm not sure if this the right file location but I know i did change the hellanzb.conf file that was located in the .lottanzb directory). After making these changes I ensured that both hellanzb and lottanzb were not running and then I started lottanzb. Once again the .nzb file would stay at 0%. So now at this point I'm turning to the lottanzb community really hoping that someone knows how to fix this because Lottanzb is soooooooooooooo much better than all of the other linux usenet clients and i really dont want to have to use an inferior piece of software due to just a little glitch. So does anyone have any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
LottaNZB Edit question
Assignee:
No assignee Edit question
Solved by:
Severin Heiniger
Solved:
2010-02-28
Last query:
2010-02-28
Last reply:
2010-02-28
lfcobra (lfcobra) said : #1

Just a clarification: The 2nd time i uninstall i did do an apt-get remove first and THEN used find to locate all the dot files that got left behind and then deleted them.

Best Severin Heiniger (severinh) said : #2

Hi lfcobra,

first of all, let me tell you that your flattering comments are really appreciated. And thanks for the detailed description of your problem.

As you already mentioned, the problem is indeed with HellaNZB, although I've never heard of this specific problem before (plenty of other have been reported though). Unfortunately, it's not possible for me to give you instructions on how to get rid of the problem right away. But we'll try to track the problem down.

Starting with LottaNZB 0.5.0, the LottaNZB configuration directory has changed from ~/.lottanzb to ~/.config/lottanzb. Also, for existing users, the HellaNZB directory (for incomplete downloads etc.) will remain ~/.hellanzb, while for new users, ~/.local/share/hellanzb will be used instead. So, you could try to delete all of these directory. You might have done that already as you used the "find" command. Launching LottaNZB 0.5 again will cause the directories to be created again. Next, you might want to shut LottaNZB down again and edit ~/.config/lottanzb/hellanzb.conf and set Hellanzb.SMART_PAR to False. It might also be useful to log all HellaNZB debug messages to a file on your desktop using the line

Hellanzb.DEBUG_MODE = "~/Desktop/hellanzb_debug"

Don't forget to remove the "# " at the beginning of the line. After that, start downloading again using LottaNZB. If the problem persists, you can have a look at the hellanzb_debug file on your Desktop. It (hopefully) contains an explanation.

I'd appreciate it if you got back to me, no matter if the above helped or not.

We're currently in the process of porting LottaNZB to the new SABnzbd backend due to the fact that HellaNZB isn't maintained anymore and suffers from quite a few bug. We really intend to preserve LottaNZB's ease-of-use while making it even more stable thanks to the new backend. See http://www.lottanzb.org/2009/06/thoughts-about-the-future-of-lottanzb/ and http://www.lottanzb.org/2010/02/progress-report/ for more information.

Regards,
Severin

lfcobra (lfcobra) said : #3

Well the good news is that lottanzb is working again! The bad news is i'm not exactly sure why. I completely uninstalled everything particularly paying attention to the file locations you specified. I then reinstalled using the 0.5.3 ubuntu package found on the download page. I then modified ~/.config/lottanzb/hellanzb.conf setting Hellanzb.SMART_PAR to False. I decided to give it a try before turning on the debug mode and surprisingly enough it worked. So I'm thinking either I missed a file when I was deleting hellanzb and lottanzb files left after uninstalling or maybe I incorrectly modified the hellanzb.conf file. Either way it works now! YAY!

Thank you very much for the quick reply to my problem! I read your posts about changing the backend of lottanzb to SABnzbd and I am very excited and hopeful about testing future releases of such a great piece of your software when they become available. Please keep up the excellent work!

lfcobra (lfcobra) said : #4

Thanks Severin Heiniger, that solved my question.