How configure loggerhead in CentOS

Asked by Angelo on 2013-09-16

Hello everyone.

I've wasted many days trying to configure loggerhead to correctly work on a CentOS server.

I'm using Bazaar as version control system. I had an old server (Ubuntu 11.04) and everything works perfect, I installed Bazaar and then I installed and configured loggerhead, so I was able to view, via web browser, the content in the Bazaar repository by browsing to "myserver:XXXX".

Now, I need to migrate Bazaar to a CentOS server (Centos 6). I succesfully installed Bazaar, but following the same steps and making everything in the same way, I can't make loggerhead work.

When I execute "service loggerheadd start", I got the right answer

Loggerhead is running.
This server is listening on port XXXX.

But when I try to access via web, browsing to "myserver:XXXX" I got the error page saying:

Unable to connect
Firefox can't establish a connection to the server at myserver:XXXX.

Does anyone know how to solve this? Thanks in advance

Question information

Language:
English Edit question
Status:
Solved
For:
loggerhead Edit question
Assignee:
No assignee Edit question
Solved by:
Angelo
Solved:
2013-09-23
Last query:
2013-09-23
Last reply:
2013-09-16
Andrew Bennetts (spiv) said : #1

Sounds like it may be a firewall problem. Perhaps CentOS has a different default firewalling policy than you're used to.

If you try browsing from the server itself (e.g. using wget or curl on the command line, “wget http://localhost:XXXX/” or similar) does it work?

Jelmer Vernooij (jelmer) said : #2

On Mon, Sep 16, 2013 at 01:41:27PM -0000, Andrew Bennetts wrote:
> Question #235817 on loggerhead changed:
> https://answers.launchpad.net/loggerhead/+question/235817
>
> Status: Open => Needs information
>
> Andrew Bennetts requested more information:
> Sounds like it may be a firewall problem. Perhaps CentOS has a
> different default firewalling policy than you're used to.
>
> If you try browsing from the server itself (e.g. using wget or curl on
> the command line, ???wget http://localhost:XXXX/??? or similar) does it
> work?
You might also want to verify that loggerhead is still running by the time that
you're trying to connect to it. Is it showing up in ps?

Jelmer

Angelo (acordinz) said : #3

Thanks both of you for your answers.

Andrew: I try browsing in the server by using a text-based web browser (elink) and it works. I was able to access and browse folders. Then I tried the same (elink), but with a different machine, and it didn't work, so I think it could be a firewall problem or something similar.

Jelmer: Before and after I try to connect to loggerhead via web browser I run a "service loggerheadd status" and I always get the same answer "loggerhead is running. This server is listening on port XXXX"

Angelo (acordinz) said : #4

Ok, I just had to enable the port for tcp connection on the CentOS server. Now everything works perfect.

Thanks for your help