Problem with my usb drive, says it's less than 579mB but it is 1 GB

Asked by manntraxx on 2008-11-06

I have a 1 GB usb
I'm running a ubuntu 8.04.1 live cd
the usb is formatted in fat16, when i run the sudo liveusb it founds: "unknown vendor USB (dev/sdb) 0MB" and when i press execute it says "This device has less than 579 MB capacity.
It cannot be used."

Please help?

Question information

Language:
English Edit question
Status:
Answered
For:
liveusb Edit question
Assignee:
No assignee Edit question
Last query:
2008-11-06
Last reply:
2008-11-21
probono (probono) said : #1

Please try reformatting the drive as one large Fat32 partition, and then try again.

mntrx (manntraxx) said : #2

Does not help.

rhobincu (rhobincu) said : #3

I had the same problem, here's how it worked for me:

WARNING! As an example I'm using the /dev/sdb here as the USB memory stick. Make sure you use the correct one as you will destroy all data from that disk.

First you need to create a primary partition. Use

fdisk /dev/sdb

I'm assuming there are no partitions on the drive. If there are, use the menu to delete them.
Press "n" to create a new partition. Select "p"rimary and index "1". Leave cylinder settings how they are unless you know what you're doing (press Enter for default values), then press "w" to write the partition table.

Then, you need to format the new partition which should appear as /dev/sdb1. Type

mkfs.vfat /dev/sdb1

Remove the USB stick and plug it back in. At this point, all should work like a charm.

Can you help with this problem?

Provide an answer of your own, or ask manntraxx for more information if necessary.

To post a message you must log in.