Getting dependency error at launch of liveusb

Asked by vince1977


After booting on the mac from the liveCD and plugging in the USB stick, I double-click on the liveUSB creator which launches the package installer...all is good so far.

But the package installer then brings up an error that reads :

Error: Dependency is not satisfiable: syslinux

So I have tried apt-get to get syslinux installed but the terminal shows another error (E: Could not find syslinux package), and I then tried editing /etc/apt/sources.list to uncomment all commented out repos in there, but to no avail...

Any help would be much appreciated.


Question information

English Edit question
liveusb Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
David Art (adcomp) said :

hello ,

Have you update after modify sources.list ..? ( sudo apt-get update )
-- >

But I have same error with syslinux complied .. missing /usr/lib/syslinux/mbr.bin

My 2 cents ..

Revision history for this message
KrzyK (chris-kobrzak) said :

Hi vince1977,

I had the same problem when I was trying to install the .deb package straight away rather than downloading to the home directory in the first place and then launching the installer. When I got that dependency error message, I went to the /tmp directory, copied the liveusb installer to the desktop:

$ cp /tmp/liveusb_0.1.0_all.deb /home/ubuntu/Desktop/

then added all permissions:

$ cd /home/ubuntu/Desktop/
$ chmod 0777 liveusb_0.1.0_all.deb

and after that the problem was gone.

I hope this helps.


Can you help with this problem?

Provide an answer of your own, or ask vince1977 for more information if necessary.

To post a message you must log in.