linuxdcpp ppa debian lenny install problem

Asked by Vitaliy Okulov on 2010-01-02

When i try to install deb file from ppa on debian lenny i recieve error:

$ sudo dpkg -i linuxdcpp_1.1.0-0ubuntu1~bzr345_i386.deb
dpkg - warning: downgrading linuxdcpp from 1.1.0-1 to 1.1.0-0ubuntu1~bzr345.
(Reading database ... 336811 files and directories currently installed.)
Preparing to replace linuxdcpp 1.1.0-1 (using linuxdcpp_1.1.0-0ubuntu1~bzr345_i386.deb) ...
Unpacking replacement linuxdcpp ...
dpkg: dependency problems prevent configuration of linuxdcpp:
 linuxdcpp depends on libnotify1 (>= 0.4.5); however:
  Version of libnotify1 on system is 0.4.4-3.
 linuxdcpp depends on libstdc++6 (>= 4.4.0); however:
  Version of libstdc++6 on system is 4.3.2-1.1.
dpkg: error processing linuxdcpp (--install):
 dependency problems - leaving unconfigured
Processing triggers for menu ...
Processing triggers for man-db ...
Errors were encountered while processing:
 linuxdcpp

I think builded package only for latest ubuntu OS. So please build package for other ubuntu OS version.

Question information

Language:
English Edit question
Status:
Answered
For:
LinuxDC++ Edit question
Assignee:
No assignee Edit question
Last query:
2010-01-10
Last reply:
2010-05-15

This question was originally filed as bug #502314.

Steven Sheehy (steven-sheehy) said : #1

Converting to question since it's not a bug, you're just asking for a Jaunty PPA.

Steven Sheehy (steven-sheehy) said : #2

I've added a jaunty ppa of rev 345.

sudo dpkg -i linuxdcpp_1.1.0-0ubuntu1~bzr345~jaunty1_i386.deb
dpkg - warning: downgrading linuxdcpp from 1.1.0-1.1 to 1.1.0-0ubuntu1~bzr345~jaunty1.
(Reading database ... 336876 files and directories currently installed.)
Preparing to replace linuxdcpp 1.1.0-1.1 (using linuxdcpp_1.1.0-0ubuntu1~bzr345~jaunty1_i386.deb) ...
Unpacking replacement linuxdcpp ...
dpkg: dependency problems prevent configuration of linuxdcpp:
 linuxdcpp depends on libgtk2.0-0 (>= 2.16.0); however:
  Version of libgtk2.0-0 on system is 2.12.12-1~lenny1.
dpkg: error processing linuxdcpp (--install):
 dependency problems - leaving unconfigured
Processing triggers for menu ...
Processing triggers for man-db ...
Errors were encountered while processing:
 linuxdcpp

Olorin (vivliofika) said : #4

I have no problems with if I use sid. Also I think sid is stable for now.

Maybe, but i use lenny as official stable release.

Steven Sheehy (steven-sheehy) said : #6

Looks like Launchpad doesn't support building PPAs for Debian: https://bugs.launchpad.net/soyuz/+bug/188564

laslas (laslas66) said : #7

To install the linuxdcpp-ppa for jaunty on lenny (dpkg -i linuxdcpp_1.1.0-0ubuntu1~bzr345~jaunty1_amd64.deb) you have to use the lenny-backports - repository to get a newer version libgtk. (See http://www.backports.org/dokuwiki/doku.php?id=instructions on how to setup the backports-repository for lenny)
After the repository has been added use:
apt-get -t lenny-backports install libgtk2.0-0
to update libgtk to a more recent version so you are able to install linuxdcpp.

Works fine here but sometimes linuxdcpp exits with "getötet" after running for several days.

Tehnick (tehnick) said : #8

>Maybe, but i use lenny as official stable release.

linuxdcpp packages from Ubuntu Hardy is suitable for Debian Lenny. So they can be simply builded in the same PPA.

Can you help with this problem?

Provide an answer of your own, or ask Vitaliy Okulov for more information if necessary.

To post a message you must log in.